Untitled Document

Drive Rescue - Outil de récupération de données

Drive Rescue est un outil de récupération de données pour Windows® 95, 98, ME, NT, 2000 et XP.

Ce que Drive Rescue peut faire pour vous:

  • Trouver n'importe quelles données perdues et/ou, supprimées sur votre disque dur même si la table de partition est perdue ! Les données perdues, à la suite d'un accident(faille) du système peuvent aussi être récupérées.

Ce que Drive Rescue ne peut pas faire pour vous:

  • Trouver des données sur un disque dur physiquement endommagé!

Particularités

Systèmes de fichiers supportés: FAT 12/16/32 (disques durs, Smartmedia™, Compact Flash™, Memory Stick et autres)

Equipement requis:

  • Microsoft® Windows® 95, 98, ME, NT, 2000 ou XP
  • On recommande un deuxième disque dur pour le rétablissement

Combien coûte-t-il ? C'est le mieux ! Rien. Ce programme est un Logiciel public. Vous pouvez le distribuer librement à vos amis et le faire connaitre.

Contact

Pour toutes vos questions, vous pouvez employer le contact forme. Vos réactions seront toujours les bienvenues

Licence

This software is provided as freeware and you can use it only if you accept the following:

THIS SOFTWARE IS PROVIDED BY ALEXANDER GRAU "AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL ALEXANDER GRAU BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Drive Rescue - Copyright © 2001, 2002 by Alexander Grau, All rights reserved

Microsoft and Windows are trademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.


En quatre étapes vous récupérez vos fichiers supprimés!

Pas 1: Mise en route de Drive Rescue

Pas 2: Choisissez votre disque

Pas 3: Choisissez votre fichiers et répertoires supprimés
Pas 4: Sauvez-les Simplement à un autre disque dur!

Voilà! C'est tout


Travaux dirigés

Comment récupérer mes données...

  1. Les fichiers ont été supprimés - la poubelle a été vidée

  2. Les données sont perdues

  3. Le disque dur a fait l'objet d'un formatage classique

  4. Un volume est perdu, par exemple, la table de division est endommagée

  5. Windows est endommagé et non bootable
  1. Les fichiers ont été supprimés - la poubelle a été vidée

    Choisissez Disque dans le menu Fichier.

    Choisissez le disque logique qui contient les données supprimées.

    Cherchez votre fichier supprimé dans le dossier [image] Effacés.

    Choisissez votre fichier (pour plusieurs fichiers utiliser les touches CTRL ou SHIFT) et sauvez votre fichier sur un autre disque grâce à la commande Enregistrer sous… du menu Fichier.
    De plus vous pouvez chercher un fichier supprimé / perdu en passant par le menu Fichier/Rechercher    .

  2. Les données sont perdues

    Choisissez Disque dans le menu Fichier.

    Choisissez le disque logique qui contient les données supprimées.

    Sélectionner Rechercher les données perdues dans le menu Outils. Une fenêtre apparaît et vous permet de délimiter la recherche (par exemple si vous savez que le fichier / répertoire est placé au début du disque, placer le curseur « dernier cluster » un peu plus en retrait).

    Une fois la recherche terminée, voir le résultat dans le dossier     [image] Perdus.

    Choisissez votre fichier (pour plusieurs fichiers utiliser les touches CTRL ou SHIFT) et sauvez votre fichier sur un autre disque grâce à la commande Enregistrer sous… du menu Fichier.

    Important: Si un fichier est trouvé avec nom ou une taille inconnue (par exemple cluster40.jpg), vous pouvez corriger le nom / dimension en choisissant Propriétés dans le menu Fichier. Si le fichier est trop petit, changer sa taille tout simplement.
    En plus d'analyser les clusters, vous pouvez chercher un fichier / répertoire (ou pour plusieurs fichiers) en sélectionnant Rechercher… dans le menu Fichier.

  3. Le disque dur a fait l'objet d'un formatage classique.

    Passez toutes les étapes à partir du 2.

    Important : Ouvrir le disque et enregistrer vos données en choisissant l'option "aucune FAT" !

  4. Un volume est perdu, par exemple, la table de division est endommagée

     Choisissez le Disque dans le menu Fichier.

    Choisissez le Disque physique qui contient la partition supprimées. Puis cliquer sur le bouton Rechercher des disques logiques...

    Une fenêtre apparaît et vous permet de délimiter la recherche (par exemple si vous savez que le fichier / répertoire est placé au début du disque, placer le curseur « dernier secteur » un peu plus en retrait).

    Une fois la recherche terminée et un disque logique trouvé, choisissez le disque sous disque logique, si le format semble être correct. Il n'est pas exceptionnel de trouver plus de lecteurs que ce qui a été installé. La raison est qu'il y a plusieurs copies du secteur de boot sur le disque dur. (c'est ce qui contient les informations sur les disques logiques). Utiliser la fonction Aperçu pour trouver le bon disque logique.

    Après avoir sélectionné le lecteur, aller dans le dossier     [image] Root. Choisissez votre fichier (pour plusieurs fichiers utiliser les touches CTRL ou SHIFT) et sauvez votre fichier sur un autre disque grâce à la commande Enregistrer sous… du menu Fichier.

    Vous pouvez chercher un fichier / répertoire supprimé (ou plusieurs fichiers / dossiers) en sélectionnant Rechercher… dans le menu Fichier.

  5. Windows est endommagé et non bootable

    Drive Rescue nécessite Windows pour fonctionner. Il faut donc utiliser un second disque avec Windows installé et Drive Rescue installé. Configurer ce disque en maître et le disque endommagé en esclave.

Microsoft et Windows sont des marques déposées de Microsoft Corporation. Toutes autres marques déposées sont la propriété de leurs propriétaires respectifs.


Introduction à la table d'allocation des fichiers (FAT)

Tous les disques dur sont constitués de la façon suivante :

Le procédé d'écriture
Le système d'exploitation écrit les informations systèmes comme la taille du fichier et le premier cluster du réperpertoire, la position dans la FAT, et les données elles-même dans la zone de données.

Le procédé de lecture
(1) Les informations systèmes, comme le nom du fichier, sa taille et le premier cluster sont déterminés par une entrée.
(2) D'autres clusters sont trouvés dans la table d'allocation des fichiers (FAT) et sont lus d'après les clusters correspondants dans la zone de données.

Les fichiers systèmes sont créés à partir d'un certain nombre de zone spéciales du disque mises de côtés lorsque le disque est formaté : la MBR, la table de partition, la table d'allocation des fichiers (FAT) et le "root". Au plus bas niveau, le disque est organisé en morceaux de 512 octets appelés "secteurs". La FAT alloue un espace pour les fichier appelé "cluster", composé d'un ensemble de secteurs.

Un secteur de partition principal (boot record), est un secteur qui contient du code pouvant ête exécuté par l'ordinateur. La MBR est le premier secteur que l'ordinateur exécute quand il accède au disque dur. De plus, le secteur de boot contient d'importantes informations sur la Fat, par exemple la taille des clusters, et leurs positions dans la table d'allocation des fichiers, la zone de données et le "root".

La table d'allocation des fichiers (FAT), qui se trouve après le secteur de boot, est une base de données qui associe l'emplacement des clusters aux fichiers… Il y a une entrée (tous les 12, 16 ou 32 bits) pour chaques clusters.

Les 2 premières entrées sont réservées pour le système de fichiers, la troisième et les suivantes sont allouées à la zone de données. Les fichiers enregistrés dans la zone de données ne sont pas obligatoirement enregistrés les uns à la suite des autres, et c'est pourqoi, le système d'exploitation a besoin de savoir où se trouvent les fichiers complets dans la zone de données. C'est le travail de la FAT. Pour chaque cluster utilisé par un fichier, mais qui n'est pas le dernier cluster de ce fichier, la FAT contient l'adresse du cluster qui contient la suite du fichier. Lorsqu'un programme demande au système d'exploitation d'afficher le contenu d'un fichier, l'OS doit commencer par lire le premier cluster qui contient ce fichier. Il cherche ensuite l'entrée correspondante dans la FAT, et connaît ainsi, le cluster suivant qui contient la suite du fichier. Il peut alors lire le contenu du cluster dans la zone de données. Uen fois ce cluster complètement lu, l'OS répète cette opération jusqu'à ce que le fichier soit lu entièrement. Cette organisation est appelé "table de chaînage des clusters".

La FAT contient quelques entrées spéciales pour indiquer que :

  • le cluster est libre (non utilisé par un fichier) (0000H pour la Fat16)
  • le cluster contient un ou plusieurs secteurs qui sont physiquement endommagés ou qui ne peuvent ête utilisés. (FFF7F for FAT16)
  • le cluster est le dernier utilisé pour un fichier (FFF8-FFFFH pour la FAT16), également appelé "End Of File (EOF)"

Mais comment le système d'exploitation sait quels fichiers se trouvent sur le disque et où trouver le premier cluster de ces fichiers ? C'est pour cette raison quel les entrées sont aussi stockées dans la zone de données. Chaque entrée a une taille de 32 octets et inclus les informations sur le fichier ou dossier, la taille, le premier cluster utilisé et ses attributs.


Données perdues

La perte de données est dûe au fait qu'une entrée et/ou la FAT sont supprimées ou contiennent des informations incorrectes. Le système d'exploitation accède aux données de la façon suivante : Lecture des données de l'entrée -> Lecture des données dans la zone de données -> Lecture de l'information depuis la Fat et ainsi de suite jusqu'à ce que le fichier soit complètement lu. Si l'entrée et/ou la Fat sont incorrectes ou supprimées, le système d'exploitation rien lire de plus bien que les données soient toujours dans la zone de données. C'est la raison pour laquelle les utilisateus pensent que leurs donées sont perdues, alors qu'en réalit elles sont toujours disponibles. Retrouver ces données peut-être cependant très complexe parfois, puisque l'intégralité du disque doit être examiné.

Perte des données elles-mêmes.
Les données sont perdues pour de bon, si le contenu est endommagé ou écrasé. (le fichier n'était pas perdu à cause d'une information incorrecte de la FAT ou de l'entrée).

Cela peut-être dû aux raisons suivantes :

  1. Le disque dur ou la disquette sont physiquement endommagés.
  2. Un virus a détruit les données
  3. L'ériture d'autres fichies sur le disque à entrainé la modifcation de certains clusters. Dans ce cas, seule une partie des données peut-être récupérée.


Données effacées

Si l'utilisateur efface un fichier (et non pas simplement placé dans le presse-papier de Windows), la première lettre de l'entrée, est remplacée par un caractère spécial (E5 en hexadécimal, 229 en décimal). En plus, les informations sur l'ordre des clusters sont également effacées lors de la suppression. Cela n'a pas d'importance si le fichier n'était pas fragmenté (c'est à dire que les clusters du fichiers on t été enregistrées successivement).
Avec un lecteur fragmenté (cela est fréquent avec l'enregistrement et l'effacement fréquent des données), la chance de retrouver des fichiers est relativement faible. Cependant, si le fichier est visible dans le dossier "Effacés" dans Drive Rescue, vous pouvez essayer de le récupérer, et Drive Rescue s'assurera qu'il n'est pas fragmenté.


Mesures de précaution à prendre

Vous pouvez augmenter les chances de récupérer des données, si vous considérez les points suivants

  1. Ne stockez pas les dossiers importants dans le répertoire racine.
    Les dossiers, qui sont stockés dans le répertoire racine, sont plus sensibles à une perte par formatage, parce que les entrées de dossier sont placé à côté de la racine. Évitez de stocker des dossiers directement à la racine puisque si le dossier disparaît, 'entrée de répertoire est endommagée. En cas d'urgence, on peut récupérer des données très rapidement si elles sont dans un sous-répertoire.

  2. Défragmentez le disque dur régulièrement
    Des données sont stockées dans des clusters consécutifs, S'il y a suffisament d'espace libre. La suppression et l'écriture répétées fragmentent le disque.

    Un exemple :

    (1) (2) (3) (4) (5) (6) (7) (8) - pourrait représenter 8 petits fichiers

     (1) (2) (3) (4) (5) (6) (7) (8) - maintenant on supprime les fichiers (2), (4), (7) et (8)

    (1) (9) (3) (9) (5) (6) (9) (9) - le disque est fragmenté si un fichier plus grand est stocké

    Si des données sont supprimées du disque, de nouvelles données peuvent prendre la place libre. Si les nouvelles donnée sont plus grandes que les précédentes, les données sont mises à la suite mais en fragments.
    Lorsqu'il lit des données fragmentées, le disque dur doit "sauter". La vitesse de lecture et écriture est réduite. Afin de rendre le procédé de lecture et d'écriture plus efficace, il est nécessaire de réorganiser les fragments du disque. Après une défragmentation, les données sont replacées dans un ordre séquentiel et ressemblent ensuite à cela :

    (1) (9) (9) (9) (9) (3) (5) (6) - après la défragmentation

    Un disque souvent fragmenté affectera l'efficacité de la récupération de données, par exemple si la Fat a été supprimée par un formatage ou un virus. Il est alors nécessaire de déterminer exactement la position d'un fichier fragmenté sur le disque perdu. Si les données sont toujours présentes, la récupération est possible en se basant sur les informations de position et de taille.

    Important: Un disque non fragmenté améliorera le taux de récupération parce que les données complètes sont stockées au début du premier cluster d'un dossier.

  3. Ne stokez pas de données importantes sur un disque de petite capacité
    Plus la capacité du disque est faible, plus les chances de récupération sont basses. Les données importantes devraient être stockées sur un disque libre. Plus le disque est petit, plus le risque de fragmentation est imortant.

  4. Défragmentez votre disquette lorsque vous avez stocké des données dessus
    Le probalitité de fragmentation des disquettes est très élevée. Par conséquent, il est recommandé, avec les données importantes, de placer les fichiers dans plusieurs dossiers, et de défragmenter ensuite la disquette.

  5. N'utilisez pas un disque sur lequel vous devez récupérer des données
    N'installez pas un logiciel de récupération de données sur un disque qui contient des données à récupérer. Sinon les données risqueraient d'être remplacées par d'autres et la chance de récupérer les données serait beaucoup plus faible. Evitez de travailler avec ce disque et n'enregistrez aucune données dessus. N'utilisez pas d'autrs programmes non plus, y compris l'explorateur windows®., afin de ne pas réecrire par dessus des données importantes. Pour la récupération de données vous devriez utiliser un second disque dur.


Drive Rescue - uno strumento di recupero dati persi e/o cancellati

Drive Rescue è uno strumento di recupero dati per utenti di Windows® 95, 98, ME, NT, 2000 e XP.

Ecco cosa Drive Rescue può fare per te:

  • Trovare ogni dato perso e cancellato sul tuo drive (per esempio hard disk), persino se la tabella delle partizioni è stata persa! Possono inoltre essere recuperati dati persi, cioè risultanti da un crash di sistema.

Ecco invece cosa Drive Rescue NON può fare per te:

  • Trovare dati su un drive fisicamente danneggiato!

Caratteristiche

File systems supportati: FAT 12/16/32 (usati da hard disk, disks, Smartmedia™, Compact Flash™, Memory Stick e altri) Requisiti di sistema:

  • Microsoft® Windows® 95, 98, ME, NT, 2000 o XP
  • Un secondo hard disk è raccomandato per il recupero dei dati

Quanto costa Drive Rescue? Ecco la cosa più grande!! Niente. Questo programma è freeware. Tu puoi e dovresti distribuirlo gratuitamente ai tuoi amici.

Contatti

Per ogni questione concernente Drive Rescue, puoi usare il modulo di contatto. Ogni tipo di feedback è sempre apprezzato.

Licenza

Questo software è fornito come freeware e tu puoi usarlo solo se accetti quanto segue:

THIS SOFTWARE IS PROVIDED BY ALEXANDER GRAU "AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL ALEXANDER GRAU BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Drive Rescue - Copyright © 2001, 2002 Di Alexander Grau, Tutti i diritti riservati

Microsoft e Windows sono marchi commerciali di Microsoft Corporation. Tutti gli altri marchi commerciali sono di proprietà dei loro rispettivi proprietari.


Ripristina i tuoi file cancellati in quattro passi!

Passo 1: Avvia Drive Rescue

Passo 2: Scegli il tuo drive

Passo 3: Seleziona i tuoi files/directories cancellati
Passo 4: Salvali semplicemente in un altro hard disk!

E' tutto!


Breve corso

Come ripristinare i miei dati...

  1. I files sono stati cancellati o il cestino di Windows è stato svuotato

  2. Si sono persi files/directories

  3. L'hard disk è stato formattato velocemente

  4. Si è perso un volume, per esempio a causa di una tabella delle partizioni danneggiata

  5. Windows è danneggiato e non avviabile
  1. I files sono stati cancellati o il cestino di Windows è stato svuotato

    Seleziona Drive dal menu Object (Oggetto).

    Seleziona il drive contenente i dati cancellati come Logical drive (drive logico).

    Cerca i tuoi file in [image] Deleted (Cancellati).

    Seleziona il file (per più files usa i tasti CTRL o SHIFT ) e salvalo/i in un altro drive selezionando Save to ... (Salva in…) dal menu Object (Oggetto). In aggiunta, puoi cercare un file perso o cancellato (o più files) selezionando Find (Trova) dal menu Object (Oggetto).

  2. Si sono persi file/directories

    Seleziona Drive dal menu Object (Oggetto).

    Seleziona il drive contenente i files/directories persi come Logical drive (drive logico).

    Seleziona Find lost data (Trova dati persi) dal menu Tools (Strumenti). Apparirà una finestra di dialogo che ti consentirà di circoscrivere la ricerca (per esempio, se sai che il file/directory è posto più oltre, muovi il cursore della barra Start cluster (cluster di partenza) alla sua destra).

    Dopo che è stata completato l'esame dei cluster, ricerca la tua directory nella cartella [image] Lost (Persi).

    Seleziona il tuo file (per più files usa i tasti CTRL o SHIFT) e salva il tuo file in un altro drive selezionando Save to … (Salva in...) dal menu Object (Oggetto).

    Importante: Se Drive Image troverà un file con una grandezza e un nome sconosciuto (per es. cluster40.jpg), puoi correggere il nome/la grandezza scegliendo Properties (Proprietà) dal menu Object (Oggetto). Se il file è troppo piccolo, cambia semplicemente la grandezza del file in un valore più alto.

    Oltre alla scansione del cluster, puoi cercare un file cancellato/perso (o più files) selezionando Find (Trova) dal menu Object (Oggetto).

  3. L'hard disk è stato formattato velocemente

    Procedi attraverso tutti i passi come in 2.

    Importante: Per aprire il drive e salvare I tuoi dati, scegli l'opzione "no FAT (consecutiva)" poiché la FAT è stata cancellata con la formattazione rapida!

  4. Si è perso un volume, per esempio a causa di una tabella delle partizioni danneggiata

     Seleziona Drive dal menu Object (Oggetto).

    Seleziona il drive contenente la partizione cancellata come Physical drive (Drive fisico). Seleziona il bottone Find logical drive... (Trova drive logico…)

    La finestra di dialogo che apparirà ti permetterà di circoscrivere la ricerca (per esempio, se conosci che la partenza della partizione è situata più oltre, muovi il cursore della barra Start cluster (cluster di partenza) a destra).

    Dopo che la ricerca è stata completata, e un drive logico è stato trovato, seleziona il drive sotto logical drive (drive logico), se il formato sembra essere corretto. Non è strano se sono stati trovati più driver di quelli installati. Il motivo è dovuto al fatto che vi sono più copie del settore di avvio sull' hard disk (vale a dire l'unità che contiene le informazioni sul drive logico). Così, prima usa la funzione Preview (Anteprima) per ottenere il giusto drive logico.

    Dopo aver selezionato il drive, cercane il contenuto nella cartella [image] Root (Radice). Seleziona il tuo file (Per più files usa i tasti CTRL o SHIFT ) e salva il tuo file in un altro drive selezionando Save to... (Salva in….) dal menu Object (Oggetto).

    Inoltre, puoi ricercare un file perso/cancellato (o più files) selezionando Find (Trova) dal menu Object (Oggetto).

  5. Windows è danneggiato e non avviabile.

    Drive Rescue richiede Windows. Pertanto usa un secondo hard disk con Windows e Drive Rescue installato. Configura questo drive come master e il drive danneggiato come slave.

Microsoft and Windows sono marchi commerciali di Microsoft Corporation. Tutti gli altri marchi commerciali sono di proprietà dei loro rispettivi proprietari.


Introduzione alla tabella di allocazione dei file (FAT)

Ogni disco o hard disk che è stato formattato con il sistema FAT è costruito come segue:

Il processo di scrittura
Il sistema operative scrive informazioni di sistema, come la grandezza dei files e il numero del primo cluster all'inizio della directory, l'informazione della posizione nella FAT, e il dato stesso nell'area dati.

Il processo di lettura
(1) Le informazioni di sistema, come il nome del file, l'ampiezza e il numero del primo cluster sono fissate nell'inizio della directory.
(2) Ulteriori numeri di cluster sono trovati dalla tabella di allocazione dei file (FAT) e letti dai cluster corrispondenti nell'area dati.

Il file system è composto da un numero di speciali aree del disco messe da parte per organizzazione quando il disco è formattato: il master boot record, la tabella delle partizioni, il boot record (record d'avvio), la tabella di allocazione dei file (da cui il sistema FAT trae il suo nome), e la directory 'root' ('radice'). A basso livello, i dischi sono organizzati in gruppi di 512 byte denominati settori. La FAT system alloca spazio per i files ricorrendo ad una unità chiamata cluster, composta da un numero di settori.

Un boot record (record d'avvio) è un settore che contiene codice che può essere eseguito dal computer. Il master boot record è il primo record d'avvio che il computer esegue quando accede all'hard disk. Un boot record contiene inoltre importanti informazioni relative al sistema di file FAT, per esempio la grandezza del cluster e la posizione della tabella di allocazione dei file, l'area dei dati e la directory 'root'.

La tabella di allocazione dei file (FAT), localizzata oltre il record d'avvio è un database che associa i clusters del disco con i files. Ha "un'entrata" (ogni 12,16 o 32 bits) per ciascun cluster. Poiché le prime due entrate sono riservate al file system, la terza e quelle seguenti sono assegnate a clusters del disco (data area). I files salvati nell'area dati non sono necessariamente immagazzinati successivamente and quindi il sistema operativo deve sapere dove un file completo è localizzato nell'area dati. Questo è il compito della FAT. Per ogni cluster che è usato da un file, ma che non è l'ultimo cluster del file, l'entrata della FAT contiene il numero del cluster seguente usato dal file. Quando un programma chiede al sistema operative (OS) di fornire il contenuto di un file, il OS deve leggere il primo cluster di un file. Poi guarda l'entrata del primo cluster corrispondente nella FAT e individua il numero del cluster seguente dove prosegue il file . Poi legge il cluster associato nell'area dati . Dopo la completa lettura del cluster, il OS ripete questa procedura sino all'intera lettura del file. Questo modo di organizzare i files è chiamata la catena FAT.

Le entrate della FAT possono contenere alcuni valori speciali per indicare che

  • Il cluster è libero, cioè che non è in uso da un file (0000H per la FAT16)
  • Il cluster contiene uno o più settori che sono fisicamente danneggiati e che non dovrebbero essere utilizzati (FFF7H per la FAT16)
  • Il cluster è il cluster finale in un file (FFF8-FFFFH per la FAT16), denominato altresì "End Of File" - EOF - (fine del file)

Ma da dove il sistema operativo conosce che file sono sul disco e dove trova il primo cluster di questi files? Questa è la ragione d'essere delle directory entries (entrate di directory) che sono immagazzinate nella area dati. Ciascuna entrata di directory ha un'ampiezza di 32 byte e include informazioni circa il file, il nome della directory, l'ampiezza, il numero del primo cluster e i suoi attributi.


Perdita di dati

La perdita di dati risulta dal fato che le entrate di directory e/o la FAT sono cancellate o contengono informazioni non corrette. Il sistema operativo lavora nell'accesso ai files come segue: Lettura dati dall'entrata di directory -> Lettura dati nell'area dati-> Lettura informazioni dalla FAT e ripetizione sino a che il file è stato letto completamente Se le entrate di directory e/o la FAT sono incorrette o cancellate, il sistema operativo non può più leggere, sebbene sia ancora nell'area dati. Questo è il motivo per il quale gli utenti pensano che i loro dati siano persi , mentre in realtà sono ancora disponibili. Talvolta può tuttavia essere molto complesso trovare questi dati, poiché occorre esaminare l'intero drive.

Perdita dei dati (del contenuto stesso)
I dati sono completamente persi, se il contenuto è danneggiato o sovrascritto (il file non è perso a causa di informazione incorretta nella FAT o nell'entrata di directory).

Questo potrebbe essere causato da:

  1. L'hard disk/floppy disk è danneggiato fisicamente
  2. Virus o altro hanno distrutto i dati
  3. Scrittura di altri dati nel disco: alcuni o tutti i cluster di un file sono cambiati. In questo caso, solamente una parte dei dati può essere recuperata.


Dati cancellati

I dati cancellati non sono realmente persi, ma semplicemente sono ignorati dal sistema operativo. Se l'utente cancella un file (non spostato nel cestino della carta straccia di Windows), la prima lettera di un'entrata di directory è dotata di uno speciale carattere ( E5 esadecimale - per esempio. 229 decimale). Inoltre la cancellazione ha rimosso l'informazione circa l'ordine dei clusters. Questo non gioca nessun ruolo in quanto a questo, se il file non è stato frammentato (per esempio tutti i cluster del file sono stati immagazzinati in successione). Con drives frammentati (da frequenti cancellazioni e scritture) le probabilità di recupero appaiono relativamente scarse. Se comunque il file è visibile in Drive Rescue nella cartella 'Deleted' (Cancellati), puoi cercare di recuperarlo, e Drive Rescue riterrà che il file non né frammentato.


Misure precauzionali efficaci

Puoi incrementare le probabilità di recuperare files, se consideri alcuni punti.

  1. Non immagazzinare files importanti nella directory 'root' (radice).
    I files immagazzinati nella directory 'root' sono sensibili ad una perdita da formattazione rapida, poiché le entrate dei files sono set-aside nella 'root'.
    Evita di immagazzinare files direttamente nella directory 'root' in quanto spariscono se l'entrata della directory è danneggiata. In un'emergenza, uno può recuperare dati molto rapidamente se sono in una subdirectory.

  2. Deframmentare regolarmente l'hard drive
    I dati sono immagazzinati in clusters successivi, se è disponibile una locazione sufficiente libera. Ripetute operazioni di cancellazione e scrittura frammentano il drive.

    Un esempio:

    (1) (2) (3) (4) (5) (6) (7) (8) - rappresentano 8 piccoli files

     (1) (2) (3) (4) (5) (6) (7) (8) - ora i files (2), (4), (7) e (8) sono cancellati

    (1) (9) (3) (9) (5) (6) (9) (9) - se un file ampio è immagazzinato, il disco è frammentato

    Se un dato è cancellato dal disco, nuovi dati possono occupare lo spazio lasciato libero. Se i nuovi dati sono più ampi di quello vecchio, essi sono posti in un coerente raggio, ma in frammenti.
    Quando la testina dell'hard disk legge dati frammentati deve 'saltare' (cioè si muove lungo un tracciato). Così viene ridotta la velocità di scrittura e lettura.
    Al fine di rendere la procedura di lettura e scrittura efficace come prima, è necessario organizzare il disco frammentato. Dopo la frammentazione, i dati sono in ordine sequenziale e appaiono come segue:

    (1) (9) (9) (9) (9) (3) (5) (6) - dopo che il drive è stato deframmentato

    Un disco frammentato farà decrescere l'efficacia di un ripristino dati, qualora ad esempio la FAT sia stata sovrascritta da una formattazione rapida o da un virus. è quindi necessario esaminare attentamente la dispersione del file sul disco. Se comunque sono presenti dati connessi fra loro, un ripristino dei dati è rapidamente possibile, sulla base delle informazioni circa la sua posizione e la sua grandezza.

    Importante: Un disco non frammentato incrementerà la probabilità di ripristino in quanto i dati completi sono immagazzinati all'inizio del primo cluster di un file.

  3. Non immagazzinare dati importanti su drive di piccola capacità
    Più il disco è piccolo, minori sono le probabilità di ripristino dati. Dati importanti dovrebbero essere salvati su un drive vuoto. Più la capacità è piccola, maggiore è il rischio di frammentazione.

  4. Deframmenta il tuo floppy disk, dopo aver immagazzinato i dati in esso
    I dischi sono molto probabilmente frammentati . è pertanto consigliabile, quando si hanno importanti dati, distribuire i files in alcune directories e poi deframmentare il floppy disk.

  5. Non usare un drive nel quale tu desideri ripristinare dati.
    Non installare software di ripristino su drive che contengono dati per il tuo ripristino dati. I dati potrebbero in questo modo essere soprascritti e le probabilità di successo di un ripristino dati divenire modeste. Evita di lavorare con il drive e non salvare nessun tipo di dato su quello. Non utilizzare programmi, incluso Windows(R) Explorer, al fine di non sovrascrivere importanti dati cancellati. Dovresti usare un secondo hard disk per il ripristino dei tuoi dati.


Drive Rescue-Herramienta de Recuperación de Datos

Drive Rescue es una Herramienta de Recuperación de datos para usuarios de Windows® 95, 98, ME, NT, 2000 y XP.

Lo que Drive Rescue puede hacer por usted:

  • ¡Encuentra cualquier dato perdido y borrado de su unidad (P.ej. disco duro) aun cuando pierda la tabla de particiones!
    Los datos perdidos, que son el resultado de un fallo del sistema, también se pueden recuperar.

Lo que Drive Rescue NO puede hacer por usted:

  • ¡Encontrar cualquier dato en una unidad físicamente dañada!

Características

Soporte para los sistema de archivos: FAT 12/ 16/ 32 (usados por discos duros, discos, Smartmedia™, Compact Flash™, Memory Stick y otros)

Requisitos del sistema:

  • Microsoft® Windows® 95, 98, ME, NT, 2000 o XP
  • Se recomienda un secundo disco duro para la recuperación de datos

¿Cuanto cuesta? ¡Esto es lo mejor! Nada. Este programa es Freeware. Puede y debería distribuirlo libremente a sus amigos.

Contacto

Para cualquier cuestion referente a Drive Rescue, Puede usar el contact form.

License

This software is provided as freeware and you can use it only if you accept the following:

THIS SOFTWARE IS PROVIDED BY ALEXANDER GRAU "AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL ALEXANDER GRAU BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Drive Rescue - Copyright © 2001, 2002 by Alexander Grau, All rights reserved

Microsoft and Windows are trademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.


¡En cuatro pasos recupera sus archivos eliminados!

Paso 1: Ejecute Drive Rescue

Paso 2: Escoja su unidad

Paso 3: Seleccione sus archivos/directorios eliminados
Paso 4: ¡Simplemente guárdelos en otro disco duro!

¡Eso es todo!


Tutorial

Cómo recuperar mis datos...

  1. Los archivos se han eliminado o la Papelera de Reciclaje se ha vaciado

  2. Los directorios se han perdido

  3. Al disco duro se ha hecho un formateo rápido

  4. Se ha perdido un volumen, ej. debido a una tabla de particiones dañada

  5. Windows está dañado y no arranca
  1. Los archivos se han eliminado o la Papelera de Reciclaje se ha vaciado

    Seleccione Unidad (Drive) en el menú Objeto (Object).

    Seleccione la unidad como Unidad Lógica (Logical drive) que contiene los datos eliminados.

    Busque su archivo en [image] Eliminado (Deleted).

    Seleccione su archivo (para varios archivos use CTRL o TECLA MAYUSCULA) y guarde su archivo a otra unidad seleccionando Guardar directorios en... (Save to ) en el menú Objeto (Object).

    Además puede buscar un archivo eliminado / perdido (o varios archivos) seleccionando Buscar (Find) del menú Objeto (Object).

  2. Los directorios se han perdido

    Seleccione la Unidad (Drive) en el menú Objeto (Object).

    Seleccione la unidad como Unidad Lógica (Logical drive) que contiene los directorios/archivos perdidos.

    Seleccione Bucar datos perdidos (Find lost data) del menú Herramientas (Tools). La ventana de diálogo que aparece permite que delimite la búsqueda (p.ej. si sabe que el directorio/ archivo se sitúa más atrás, mueva la barra Cluster de Inicio (Start cluster) a la derecha

    Después de terminar el escaneo del directorio busque su directorio en la carpeta     [image] Perdido (Lost) .

    Seleccione su archivo (para varios archivos use CTRL o TECLA MAYUSCULA) y guarde su archivo en otra unidad seleccionando Guardar directorios en ... (Save to... ) del menú Objeto (Object).

    Importante: Si un archivo se encuentra con un nombre y tamaño desconocido (p. Ej. Cluster40.jpg) puede corregir el nombre/ tamaño seleccionando Propiedades (Properties) del menú Objeto (Object). Si el archivo es demasiado pequeño simplemente cambie el tamaño de archivo a un valor mayor.

    Además del escaneo de clústeres puede buscar un archivo eliminado/ perdido (o varios archivos) seleccionando Buscar (Find) del menú Objeto.

  3. Al disco duro se ha hecho un formateo rápido

    Proceda con todos los pasos como en 2.

    Importante: Para abrir la unidad y guardar sus datos escoja la opción "ninguna FAT (consecutivo)" ya que la FAT ha sido eliminada por el formateo rápido

  4. Se ha perdido un volumen, p. ej. debido a una tabla de particiones dañada

     Seleccione Unidad (Drive) del menú Objeto (Object).

    Seleccione la unidad como Unidad Físico (Physical drive) que contiene la partición eliminada. Seleccione Buscar unidad lógica (Find logical drive)...

    La ventana de diálogo que aparece permite que delimite la búsqueda (p.ej. si sabe que el comienzo de la partición se sitúa más atrás, mueva la barra Cluster de Inicio (Start cluster) a la derecha.

    Después de que la búsqueda se ha completado y se ha encontrado una unidad lógica, seleccione la unidad como unidad lógica (logical drive), si el formato parece ser el correcto. No es excepcional que se encuentren más discos de los que tiene instalados. La razón es que hay varias copias del sector de arranque en el disco duro (ésa es la unidad que contiene la información sobre el disco lógico).

    Después de seleccionar la unidad a examinar busque su unidad en la carpeta [image] Raíz (Root). Seleccione su archivo (para varios archivos use CTRL o TECLA MAYUSCULA) y guarde su archivo en otra unidad seleccionando Guardar en... (Save to...) del menú Objeto (Object).

    Además puede buscar un archivo eliminado/ perdido (o varios archivos) seleccionando Buscar (Find) del menú Objeto.

  5. Windows está dañado y no arranca

    Drive Rescue requiere Windows. Por consiguiente use un segundo disco duro con Windows y con Drive Rescue instalado. Configure este disco como maestro y la unidad dañada como unidad esclava.

Microsoft and Windows are trademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.


Introducción a la Tabla de Asignación del Archivo (FAT)

Cada disco o disco duro que se ha formateado con el sistema FAT está construido como sigue

El proceso de escritura (The write process)
El sistema operativo escribe la información del sistema como el tamaño de archivo y el número del primer cluster en la entrada del directorio, la información de la posición en la FAT, y los datos de ella en el área de datos.

El proceso de lectura (The read process)
(1) La información del Sistema, como el nombre de archivo, el tamaño y el numero del primer cluster se determina en la entrada del directorio.

(2) Los siguientes números de cluster se encuentran en la tabla de asignación de archivos (FAT) y se leen de los correspondientes clústeres del área de datos.

El sistema de archivos se forma por varias áreas especiales del disco situadas aparte por organización cuando se formatea el disco: el registro de arranque del maestro, la tabla de particiones, el registro de arranque, la tabla de asignación de archivos (del que el sistema FAT toma su nombre ), y el directorio raíz. A mas bajo nivel se organiza el disco en grupos de 512 bytes llamados sectores. El sistema FAT asigna el espacio para los archivos usando una unidad llamada cluster, formado por un número íntegro de sectores.

Un registro de arranque es un sector que contiene un código que puede ser procesado por la computadora. El registro de arranque del maestro es el primer registro de arranque que la computadora procesa cuando accede al disco duro. Adicionalmente, un registro de arranque contiene información importante sobre el sistema de archivos FAT, Ej. el tamaño del cluster y las posiciones de la tabla de asignación de archivos, el área de datos y el directorio raíz (root).

La tabla de asignación de archivos (FAT), localizada detrás del registro de arranque es un banco de datos que asocia clusters de espacio de disco con archivos. Tiene una entrada (cada una de 12,16 o 32 bits) para cada cluster. Ya que las primeras dos entradas se reservan para el sistema de archivos, a la tercera entrada y siguientes se les asignan a clusters de espacio de disco (área de datos). Los archivos guardados en el área de datos no se guardan necesariamente de forma sucesiva y por consiguiente el sistema operativo tiene que saber donde se localiza un archivo completo en el área de datos (data area). Ésa es la tarea de la FAT. Para cualquier cluster que es usado por un archivo pero no es el último cluster del archivo, la entrada FAT contiene el número del próximo cluster usado por el archivo. Cuando un programa pide al sistema operativo que proporcione el contenido de un archivo, el sistema operativo tiene que leer los primeros clústeres del archivo. Entonces mira el primer cluster correspondiente en la entrada de la FAT y sabe donde continúa el próximo número de cluster del archivo. Ahora lee el cluster asociado en el área de datos. Después de leer totalmente este cluster, el sistema operativo repite este método hasta que se lee el archivo entero. Esta manera de organizar un archivo se llama la cadena de la FAT.

Las entradas FAT podrían contener unos valores especiales para indicar que

  • el cluster está libre, no lo usa ningún archivo (0000H para FAT16)
  • el cluster contiene uno o más sectores que están físicamente dañados y no se deben usar (FFF7H para FAT16)
  • y el cluster es el ultimo cluster de un archivo (FFF8-FFFFH para FAT16), también llamado Final De Archivo (EOF)

¿Pero de dónde sabe el sistema operativo qué archivos hay en el disco y donde encontrar el primer cluster de ese archivo? Ésa es la razón de las entradas de directorio (directory entry), que también se guardan en el área de datos. Cada entrada de directorio tiene un tamaño de 32 bytes e incluye información sobre el nombre del archivo o directorio, su tamaño, el primer número de cluster y sus atributos.


Pérdida de datos

La pérdida de datos resulta del hecho de que las entradas de directorio y/ o de la FAT son borradas o contienen información incorrecta. El sistema operativo trabaja para acceder los archivos como sigue: Lee datos de la entrada de directorio-> Lee datos en el área de datos> Lee información de la FAT y repite desde el siguiente hasta el último paso hasta que se lea el archivo completamente. Si las entradas de directorio y/ o la FAT son incorrectos o se han eliminado, el sistema operativo no puede leer; sin embargo todavía están en el área de datos. Ésta es la razón por la qué los usuarios piensan que sus datos se han perdido - en realidad todavía están disponibles. Encontrar estos datos puede ser muy complejo a veces porque el disco entero tiene que ser examinado.

Pérdida de datos del mismo contenido
Se pierden datos completamente, si se daña la unidad o se sobrescribe (no se perdió el archivo debido a información incorrecta en la FAT o las entradas de directorio).

Esto puede tener las causas siguientes:

  1. El disco duro/ disco flexible está físicamente dañado.
  2. Virus o alguna otra acción destruyó los datos.
  3. La escritura de otros archivos al disco ha llevado a ello, algunos clústeres o todos se modificaron. En este caso sólo una parte de los datos puede ser recuperada.


Datos eliminados

Los datos eliminados no se pierden verdaderamente pero son ignorados simplemente por el sistema operativo. Si el usuario elimina un archivo (por la presente no significa enviarlo a la papelera de Windows), la primera letra de la entrada de directorio se proporciona con un carácter especial (E5 hexadecimal- Ej. 229 decimal). Además, la información sobre el orden de los clusters ha sido eliminada por el borrado. Esto no juega ningún papel al respecto, si el archivo no está fragmentado ( Ej. se guardaron sucesivamente todos los clústeres del archivo). Con unidades fragmentadas (esto está originado por eliminaciones y almacenamientos frecuentes) las oportunidades para recuperar son relativamente malas. Sin embargo, si el archivo es visible bajo la carpeta 'Eliminado' ('Deleted' ) en Drive Rescue, puede tratar de recuperarlo, y Drive Rescue dará por hecho que el archivo no está fragmentado.


Medidas de precaución eficaces

Puede aumentar las oportunidades de recuperar datos, si considera algunos puntos.

  1. No guardar archivos importantes en el directorio raíz.
    Los Archivos que se guardan en el directorio raíz son sensibles a perderse por formateo rápido, porque entradas de archivo se encuentran en la raíz.
    Evite guardar archivos directamente en la raíz, ya que el archivo desaparece, si se daña la entrada de directorio. En una emergencia puede recuperar datos muy rápidamente si está en un subdirectorio.

  2. Defragmentar la unidad regularmente
    Los datos se guardan en clusters sucesivos, si hay suficientes localizaciones conexas de almacenamiento libres. Borrados y operaciones de escritura sucesivos fragmenta el disco.

    Un ejemplo:

    (1) (2) (3) (4) (5) (6) (7) (8) - debería representar 8 archivos pequeños

     (1) (2) (3) (4) (5) (6) (7) (8) - ahora los archivos (2), (4), (7) y (8) se han eliminado

    (1) (9) (3) (9) (5) (6) (9) (9) - se fragmenta disco si se guarda un archivo grande

    Si se eliminan datos del disco, datos nuevos pueden tomar el lugar libre. Si los datos nuevos son más grandes que el archivo viejo, los datos son colocados juntos dentro de un rango coherente, pero en fragmentos.
    Cuando se leen datos fragmentados la cabeza del disco duro tiene que 'saltar' (Ej. la cabeza se mueve saltando a otro lugar). Así la velocidad de lectura y escritura se reduce.
    Para hacer el procedimiento de lectura y escritura de nuevo más eficaz, es necesario reorganizar el disco fragmentado. Después de la defragmentación los datos están en orden secuencial y entonces aparecen de esta manera:

    (1) (9) (9) (9) (9) (3) (5) (6) - después de que el disco se defragmente

    Normalmente un disco fragmentado degrada la eficacia de la recuperación de datos, si por ejemplo. la FAT es borrada por un formateo rápido o un virus. Entonces es necesario analizar exactamente, cómo un archivo se ha esparció por el disco. Sin embargo, si los datos conexos están presentes, la recuperación de datos es muy posible rápidamente conociendo la información sobre su posición y tamaño.

    Importante: Un disco no fragmentado aumenta el ratio de recuperación porque se guardan los datos completos desde el principio del primer cluster de un archivo.

  3. No guardar datos importantes en unidades de pequeña capacidad
    La probabilidad de recuperación es menor, cuanto más pequeña sea la capacidad del disco . Se deben guardar los datos importantes en un disco libre. Cuanto más pequeña sea la capacidad de la unidad , más alto el riesgo de fragmentación.

  4. Defragmentar su disquete, después guardar datos en él
    Los discos están fragmentados muy probablemente. Por consiguiente, es aconsejable teniendo datos importantes, distribuir los archivos en varios directorios y defragmentar el disco flexible.

  5. No usar una unidad que necesite para la recuperación
    No instale software de recuperación de datos en una unidad que contiene datos para su recuperación. De otra manera los datos pueden sobrescribirse y el éxito en la recuperación es menor. Evite trabajar con la unidad y no guarde ningún dato en ella. No use un programa usual, incluyendo Windows Explorer, para no sobrescribir datos eliminados importantes.
    Para la recuperación de datos debería usar un segundo disco duro.


Drive Rescue - Undelete and data recovery tool

Drive Rescue is a data recovery tool for Windows® 95, 98, ME, NT, 2000 and XP users.

What Drive Rescue can do for you:

  • Find any lost and deleted data on your drive (e.g. hard disk) even if the partition table is lost!
    Lost Data, that is the result of a system crash can also be recovered.

What Drive Rescue can NOT do for you:

  • Find any data on a physically damaged drive!

Features

Supported file systems: FAT 12/16/32 (used by hard disks, disks, Smartmedia™, Compact Flash™, Memory Stick and other)
System requirements:

  • Microsoft® Windows® 95, 98, ME, NT, 2000 or XP
  • Second hard disk is recommended for recovery

How much does it cost? That's the greatest! Nothing. This program is Freeware. You may and should freely distribute it to your friends.

Contact

For any question regarding Drive Rescue, you can use my contact form. Every kind of feedback is always appreciated.

License

This software is provided as freeware and you can use it only if you accept the following:

THIS SOFTWARE IS PROVIDED BY ALEXANDER GRAU "AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL ALEXANDER GRAU BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Drive Rescue - Copyright © 2001, 2002 by Alexander Grau, All rights reserved

Microsoft and Windows are trademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.


In four steps you recover your deleted files!

Step 1: Run Drive Rescue

Step 2: Choose your drive

Step 3: Select your deleted files/directories
Step 4: Simply save them to another hard disk!

That's it!


Tutorial

How to recover my data...

  1. Files have been deleted or Windows-recycle bin has been emptied

  2. Files/directories are lost

  3. Hard disk has been quick-formated

  4. A volume is lost, e.g. due to damaged partition table

  5. Windows ist damaged and not bootable
  1. Files habe been deleted or Windows-recycle bin has been emptied

    Select Drive from Object menu.

    Select drive as Logical drive which contains the deleted data.

    Look for your file from [image] Deleted.

    Select your file (for several files use CTRL or SHIFT key) and save your file to another drive by selecting Save to... from Object menu.
    In addition you can search for a deleted/lost file (or for several files) by selecting Find from Object menu.

  2. Files/directories are lost

    Select Drive from Object menu.

    Select drive as Logical drive which contains the lost files/directories.

    Select Find lost data from Tools menu. The appearing dialog windows allows you to delimit the search (e.g. if you know the file/directory is situated more behind, move the track bar Start cluster to the rigtht).

    After completion of cluster scan look for your directory at folder     [image] Lost.

    Select your file (for several files use CTRL or SHIFT key) and save your file to another drive by selecting Save to... from menu Object.

    Important: If a file will be found with unknown name and size (e.g. cluster40.jpg), you can correct the name/size by choosing Properties from menu Object. If the file is too small simply change the file size to a higher value.
    In addition to the cluster scan you can search for a deleted/lost file (or for several files) by selecting Find from Object menu.

  3. Hard disk has been quick-formatted

    Proceed all steps like in 2.

    Important: To open the drive and to save your data choose the option "no FAT (consecutive)" since the FAT has been deleted by quick-formatting!

  4. A volume is lost, e.g. due to damaged partition table

     Select Drive from Object menu.

    Select drive as Physical drive which contains the deleted partition. Select button Find logical drive...

    The appearing dialog windows allows you to delimit the search (e.g. if you know the start of the partition is situated more behind, move the track bar Start cluster to the rigtht).

    After the search has been completed and a logical drive has been found select the drive under logical drive, if the format seems to be correct. It is not exceptional if more drives are found than has been installed. The reason is that there are several copies of the boot sector on the hard disk (that's the unit that contains the information about a logical drive). So first use the function Preview to get the right logical drive.

    After selection of the drive look for your drive content at folder     [image] Root. Select your file (for several files use CTRL or SHIFT key) and save your file to another drive by selecting Save to... from Object menu.

    In addition you can search for a deleted/lost file (or for several files) by selecting Find from Object menu.

  5. Windows ist damaged and not bootable

    Drive Rescue requires Windows. Therefore use a second hard disk with Windows and Drive Rescue installed. Configure this drive as master and the damaged drive as slave drive.

Microsoft and Windows are trademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.


Introduction to the File Allocation Table (FAT)

Every disk or hard disk, that has been formatted with the FAT system is built as follows

The write process
The operating system writes system information like file size and first cluster number to the directory entry, position information to the FAT, and data itself to the data area.

The read process
(1) System information, like file name, size and first cluster number is determined from the directory entry.
(2) Further cluster numbers are found from the file allocation table (FAT) and read from the corresponding clusters in the data area.

The file system exists from a number of special areas of the disk set aside for organization when the disk is formatted: the master boot record, the partition table, the boot record, the file allocation table (from which the FAT system takes its name), and the root directory. At a low level, disk are organized into 512 byte groups called sectors. The FAT system allocates space for files using a unit called a cluster, made up of an integral number of sectors.

A boot record is a sector which contains code that can is executed by the computer. The master boot record is the first boot record that the computer executes when it accesses the hard disk. Additonally a boot record contains important information about the FAT file system, e.g. the cluster size and the positions of the file allocation table, data area and the root directory.

The file allocation table (FAT), located behind the boot record is a database that associates clusters of disk space with files. It has one entry (each 12,16 or 32 bits) for each cluster. Because the first two entries are reserved for the file system, the third entry and those following are assigned to clusters of disk space (data area). Files saved in the data area are not necessarily stored successively and therefore the operating system has to know where a complete file is located in the data area. That is the task of the FAT. For any cluster that is used by a file but is not the file's last cluster, the FAT entry contains the number of the next cluster used by the file. When a program asks the operating system (OS) to provide the content of a file, the OS has to read the first cluster of a file. It then looks at the corresponding first cluster entry in the FAT and knows the next cluster number where the file continues. Now it reads the associated cluster in the data area. After this cluster is also totally read the OS repeats this method until the whole file is read. This way of organizing a file is called the FAT chain.

FAT entries may contain a few special values to indicate that

  • the cluster is free-that is, not in use by a file (0000H for FAT16)
  • the cluster contains one or more sectors that are physically damaged and should not be used (FFF7H for FAT16)
  • and the cluster is the final cluster in a file (FFF8-FFFFH for FAT16), also called End Of File (EOF)

But from where does the OS know what files are on the disk and where to find the first cluster of that files? That is the reason for the directory entries which are also stored in the data area. Each directory entry has a size of 32 byte and includes information about the file or directory name, size, first cluster number and its attributes.


Data-loss

Data-loss results from the fact that the direcotry entries and/or the FAT are deleted or contain incorrect information. The operating system works at an access to files as follows: Read data from directory entry -> Read data in the data area-> Read informationen from the FAT and repeat from next to last step until file is completely read. If the directory enties and/or the FAT are incorrect or deleted, the operating system can not read however any longer, although this is still in the data area. This is the reason why users think, their data is lost - in reality it is still available. Finding this data can be very complex however somtimes, since the entire drive has to be examined.

Data-loss of the content itself
Data is completely lost, if the content is damaged or overwritten (the file was not lost due to incorrect information in the FAT or the directory entries).

This could have the following causes:

  1. The Hard disk/floppy disk is physically damaged
  2. Viruses or something else destroyed the data
  3. Writing other files to the disk has led to it, that some or all clusters of a file were changed. In this case only a part of the data can be recoverd.


Deleted data

Deleted data is not really lost but is simply ignored by the operating system. If the user deletes a file (hereby it is not meant shifting it into the Windows waste-paper basket), the first letter of a directory entry is provided with a special character (it is E5 hexadecimal - i.e. 229 decimal). In addition, the information about the order of the clusters has been removed by the erasure however. That plays no role in this respect, if the file was not fragmented (i.e. all clusters of the file were stored successively). With fragmented drives (this originates through frequent erasure and storing) the chances for recovering looks relatively badly. If however the file is visible under the folder 'Deleted' in Drive Rescue, you can try to recover it, and Drive Rescue will assume the file is not fragmented.


Effective precaution-measures

You can increase the chances to recover data, if you consider some points.

  1. Do not store important files in the root directory.
    Files, which are stored in the root directory, are sensitive to a loss by quick formatting, because file entries are set-aside in the root.
    Avoid to store to store files directly in the root since the file disappears, if the directory entry is damaged    . In an emergency, one can recover data very quickly if it is in a sub-directory.

  2. Defragment the hard drive regularly
    Data is stored in successive clusters, if sufficient connected free storage location is available. Repeated deletion and write operations fragment the drive.

    An example:

    (1) (2) (3) (4) (5) (6) (7) (8) - should represent 8 small files

     (1) (2) (3) (4) (5) (6) (7) (8) - now files (2), (4), (7) and (8) were deleted

    (1) (9) (3) (9) (5) (6) (9) (9) - disk is fragmented if a larger file is stored

    If data is deleted from the disk, new data can take the free place. If the new data is larger than the old one however, the data is net set aside in coherent range, but in fragments.
    When reading fragmented data the head of the hard disk has to 'jump' (i.e. the head moves to the looked track). Thus the reading and write speed is reduced.
    In order to make the read and write procedure again more efficient, it is necesscary to reorganize the fragmented disk. After defragmentation, the data is in sequential order and then look in such a way:

    (1) (9) (9) (9) (9) (3) (5) (6) - after the drive is defragmented

    A usually fragmented disk will degree the efficiency of a data-rescue, if e.g. the FAT is overwritten by a quick format or a virus. Then it is necessary to analyse exactly, how a file scattered over the disk lies. If however connected data is present, a data-rescue is very quickly possible on the basis of the information about its position and size.

    Important: A non-fragmented disk will increase you rate of recovery because the complete data is stored at the beginning of the first cluster of a file.

  3. Do not store important data on drives with small capacity
    The probability of the recover is lower, the smaller the disk capacity is. Important data should be saved on a free drive. The smaller the capacity is, the higher the risk of fragmentation is.

  4. Defragment your floppy disk, after data is stored on it
    Disks are fragmented with very high probability. Therefore it is advisable with important data, to distribute the files into several directories and then defragment the floppy disk    .

  5. Do not use a drive, which you require to the data-rescue.
    Do not install recovery software on a drive that contains data for your data-rescue. Otherwise data could be overwritten and success on a data rescue becomes smaller. Avoid working with the drive and do not save any data on it. Do not use a usal program, including the Windows(R) Explorer, in order not to overwrite important deleted data.
    For the data-recovery you should use a second hard disk.


Drive Rescue - Undelete und Datenrettungstool

Drive Rescue ist ein Datenrettungstool für Benutzer von Windows® 95, 98, ME, NT, 2000 und XP.

Was Sie mit Drive Rescue machen können:

  • Verlorene und gelöschte Daten von Ihren Datenträgern (z.B. Festplatten) wiederherstellen - auch wenn die Partitionstabelle verloren gegangen ist!
    Verlorene Daten, entstanden durch eine Quick-Formatierung oder durch einen Systemabsturz, können ebenfalls wiederhergestellt werden.

Was Sie mit Drive Rescue NICHT machen können:

  • Daten auf einem physikalisch beschädigten Datenträger finden!

Features

Unterstützte Dateisysteme: FAT 12/16/32 (wird eingesetzt bei Festplatten, Disketten, Smartmedia™, Compact Flash™, Memory Stick u.a.)

Systemvoraussetzungen:

  • Microsoft® Windows® 95, 98, ME, NT, 2000 oder XP
  • Zweite Festplatte wird zum Wiederherstellen empfohlen

Was kostet dieses Programm? Das ist das Beste! Nichts. Dieses Programm ist Freeware. Sie können und sollen dieses Programm an Ihre Freunde und Bekannte weitergeben.

Kontakt aufnehmen

Fragen, die das Programm Drive Rescue betreffen, können Sie über das Kontakt Formular stellen. Jede Art des Feedbacks ist willkommen.

Lizenz

Diese Software wird als Freeware angeboten und Sie können sie nur benutzen, wenn Sie folgendes akzeptieren:

DER AUTOR ÜBERNIMMT KEINERLEI GARANTIEN HINSICHTLICH DES INHALTS DER SOFWARE, DER BENUTZUNGSMODALITÄTEN ODER EIGNUNG FÜR SPEZIFISCHE ANFORDERUNGEN. DER ERZEUGER HAFTET WEITERES WEDER FÜR FEHLER IN DER SOFTWARE NOCH FüR DIREKTE, INDIREKTE UND FOLGESCHÄDEN ODER GEWINNEINBUSSEN IN ZUSAMMENHANG MIT DER SOFTWAREVERWENDUNG. DIE INBETRIEBNAHME DER SOFTWARE SETZT DAS EINVERSTÄNDNIS DES BENUTZERS MIT DIESER EINSCHRÄNKUNG VORAUS.

Drive Rescue - Copyright © 2001, 2002 by Alexander Grau, All rights reserved

Microsoft and Windows sind Warenzeichen der Microsoft Corporation. Alle anderen Warenzeichen sind Eigentum ihrer jeweiligen Besitzer.


In vier Schritten stellen Sie Ihre gelöschten Dateien wieder her!

Schritt 1: Drive Rescue starten

Schritt 2: Laufwerk auswählen

Schritt 3: Wiederherzustellende Dateien/
Ordner auswählen
Schritt 4: Einfach auf einer anderen
Festplatte speichern!

Kaum zu glaube, daß es so einfach geht?


Tutorial

Wie stelle ich meine Daten wieder her...

  1. Dateien wurden gelöscht oder der Windows-Papierkorb wurde entleert

  2. Dateien/Verzeichnisse sind verschwunden

  3. Die Festplatte wurde mit Quick-Format formatiert

  4. Ein Laufwerk ist verschwunden, weil z.B. die Partitionstabelle ist beschädigt ist

  5. Windows ist beschädigt und kann nicht mehr gestartet werden
  1. Dateien wurden gelöscht oder der Windows-Papierkorb wurde entleert

    Wählen Sie Laufwerk im Menü Objekt.

    Wählen Sie das Laufwerk unter Logisches Laufwerk aus, welches die gelöschten Dateien enthält.

    Schauen Sie nach der Datei unter [image] Gelöscht.

    Markieren Sie die wiederherzustellenden Datei (markieren Sie mehrere Dateien mit STRG- bzw. SHIFT-Taste) und wählen Sie Speichern unter... im Menü Object, um die Datei auf einem zweiten Laufwerk zu sichern.
    Zusätzlich haben Sie die Möglichkeit, nach gelöschten/verlorenen Dateien zu suchen. Wählen Sie dazu Suchen im Menü Objekt.

  2. Dateien/Verzeichnisse sind verschwunden

    Wählen Sie Laufwerk im Menü Objekt.

    Wählen Sie das Laufwerk unter Logisches Laufwerk aus, welches die verlorenen Verzeichnisse enthält.

    Wählen Sie Suche verlorene Daten im Menü Werkzeuge. Im neu angezeigten Dialogfenster haben Sie die Möglichkeit, die Suche einzugrenzen (wenn Sie z.B. wissen, daß die Dateien/Verzeichnisse weiter hinten liegen, schieben Sie den Regler Startcluster weiter nach hinten).

    Nachdem die Suche abgeschlossen ist, s    chauen Sie nach der Datei/dem Verzeichnis unter [image] Verloren.

    Markieren Sie die wiederherzustellenden Verzeichnisse (markieren Sie mehrere Einträge mit STRG- bzw. SHIFT-Taste) und wählen Sie Speichern unter... im Menü Object, um die Dateien/Verzeichnisse auf einem zweiten Laufwerk zu sichern.

    Wichtig    : Sollte eine Datei gefunden werden, dessen Name und Größe nicht mehr ermittelt werden konnte (z.B. cluster 40.JPG), so können Sie die Dateigröße korrigieren, falls beim Speichern Dateninhalt fehlt. Wählen Sie dazu Eigenschaften im Menü Objekt und tragen Sie einen höheren Wert für die Dateigröße ein.

    Zusätzlich haben Sie die Möglichkeit, nach bestimmten gelöschten/verlorenen Dateien zu suchen. Wählen Sie dazu Suchen im Menü Objekt.

  3. Die Festplatte wurde mit Quick-Format formatiert

    Führen Sie alle Schritte so durch, wie unter 2.
    Wichtig: Wählen Sie beim Öffnen des Laufwerks und beim Speichern Ihrer Dateien jedoch die Option "kein FAT (aufeinanderfolgend)", da der FAT beim Quick-Formatieren gelöscht worden ist!

  4. Ein Laufwerk ist verschwunden, weil z.B. die Partitionstabelle ist beschädigt ist

     Wählen Sie Laufwerk im Menü Objekt.

    Wählen Sie das Laufwerk unter Physikalisches Laufwerk aus, welches die verlorene Partition enthält. Betätigen Sie den Schaltknopf Suche logisches Laufwerk...

    Im neu angezeigten Dialogfenster haben Sie die Möglichkeit, die Suche einzugrenzen (wenn Sie z.B. wissen, daß der Beginn der Partition weiter hinten liegt, schieben Sie den Regler Startcluster weiter nach rechts).

    Nachdem die Suche abgeschlossen ist, und ein logisches Laufwerk gefunden wurde, wählen Sie das gefundene Laufwerk unter Logisches Laufwerk aus, wenn das Format korrekt ist. Es ist nicht außergewöhnlich, wenn das Programm mehr logische Laufwerke findet, als eigentlich auf der Festplatte abgelegt sind. Das liegt daran, daß sich in der Regel mehrere Kopien des Bootsektors (das ist der Sektor, der die Informationen über ein logisches Laufwerk enthält) auf einer Festplatte befinden. Schauen Sie sich daher die gefundenen logischen Laufwerke zuvor mittels Vorschau durch, um das richtige Laufwerk zu ermitteln.

    Nach der Auswahl des Laufwerks s    chauen Sie nach dem Inhalt des Laufwerks unter [image] Wurzel. Markieren Sie die wiederherzustellenden Verzeichnisse (markieren Sie mehrere Verzeichnisse mit STRG- bzw. SHIFT-Taste) und wählen Sie Speichern unter... im Menü Object, um die Verzeichnisse auf einem zweiten Laufwerk zu sichern.

    Zusätzlich haben Sie die Möglichkeit, nach gelöschten/verlorenen Dateien zu suchen. Wählen Sie dazu Suchen im Menü Objekt.

  5. Windows ist beschädigt und kann nicht mehr gestartet werden

    Drive Rescue benötigt Windows. Verwenden Sie daher ein anderes Laufwerk, auf dem Sie Windows und Drive Rescue installiert haben. Dieses Laufwerk konfigurieren Sie als Startlaufwerk (Master), die beschädigte Festplatte als Slave.

Microsoft and Windows are trademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.


Einführung in die File Allocation Table (FAT)

Jede Diskette oder Festplatte, die nach dem FAT Dateisystem formatiert wurde, ist folgendermaßen aufgebaut:

Der Datei-Schreibvorgang
Das Betriebssystem schreibt Systeminformationen,wie die Dateigröße, die erste Cluster-Nummer in den Directory-Eintrag, die Positionsinformationen in den FAT, und die Daten selbst in den Datenbereich.

Der Datei-Lesevorgang
(1) Systeminformationen, wie Dateiname, Größe und erste Cluster-Nummer werden aus dem Directory-Eintrag ermittelt
(2) Weitere Cluster-Nummern werden aus der Dateizuordnungstabelle (FAT) ausfindig gemacht und die entsprechenden Cluster im Datenbereich eingelesen

Das Dateisystem besteht aus einer Anzahl von speziellen Bereichen für die Verwaltung des Datenträgers, die erstellt werden, wenn der Datenträger formatiert wird: der Master Boot Record, die Partitionstabelle,der Boot Record, die Dateizuordnungstabelle (danach ist das FAT System benannt worden), und das Wurzelverzeichnis (Root directory). Auf unterster Ebene gesehen, sind Disketten und Festplatten eingeteilt in Gruppen von 512 Bytes, sogenannte Sektoren. Das FAT System reserviert für Dateien Speicherplatz in Form von mehreren Sektoren, Cluster gennant.

Der Boot Record ist ein Sektor, der Programmcode enthält, welcher vom Computer ausgeführt wird. Der Master Boot Record ist der erste Boot Record, den der Computer beim ersten Zugriff auf die Festplatte ausführt. Darüber hinaus enthält ein Boot Record wichtige Informationen über das FAT Dateisystem, z.B. die Clustergröße, die Positionen von Dateizuordnungstabelle (FAT), Datenbereich (data area) und dem Wurzelverzeichnis (root).

Die Dateizuordnungstabelle (FAT), die sich hinter dem Boot Record befindet stellt eine Datenbank dar, welche Cluster-Speicherplatz mit Dateien assoziiert. Sie enthält einen Eintrag (jeder 12,16 oder 32 Bits groß) für jeden Cluster. Da die ersten zwei Einträge für das Dateisystem reserviert sind, ordnet man dem dritten und den folgenden Einträgen den Cluster-Speicherplatz zu (Datenbereich, data area). Dateien, die im Datenbereich abgespeichert werden, müssen nicht unbedingt aufeinander folgende Cluster belegen und daher muß das Betriebssystem (operating system, OS) wissen, wo sich die komplette Datei im Datenbereich befindet. Das ist die Aufgabe des FAT. Für jeden Cluster, der von der Datei verwendet wird und nicht der letzte Cluster ist, enthält der FAT-Eintrag die Nummer des nächsten Cluster, welche von der Datei belegt ist. Wenn ein Programm dem Betriebssystem mitteilt, auf eine Datei zugreifen zu wollen, muß das Betriebssystem zunächst den ersten Cluster der Datei lesen. Dann schaut es in dem korrespondierenden ersten Eintrag im FAT nach, um die nächste Cluster-Nummer zu ermitteln, bei welcher die Datei fortgesetzt wird. Nun liest es den im Datenbereich assoziierten Cluster und nachdem auch dieser vollständig gelesen wurde, wiederholt das Betriebssystem diese Methode solange, bis die komplette Datei gelesen wurde. Diese Art der Organisation in Form einer Kette nennt man auch FAT-Kette (FAT chain).

FAT Einträge können ein paar spezielle Werte enthalten, um anzuzeigen, daß

  • der Cluster frei ist-also nicht von einer Datei belegt ist (0000H für FAT16)
  • der Cluster ein oder mehrere Sektoren enthält, die physikalisch beschädigt sind und nicht verwendet werden sollen (FFF7H für FAT16)
  • der Cluster der letzte einer Datei ist (FFF8-FFFFH für FAT16), auch End Of File (EOF) gennant

Aber woher weiß eigentlich das Betriebssystem, welche Dateien auf einer Festplatte sind, und wie findet es den ersten Cluster heraus? Genau das ist der die Aufgabe der Directory-Einträge (directory entries), welche ebenfalls im Datenbereich abgelegt sind. Jeder Directory-Eintrag hat eine Größe von 32 Byte und bietet folgende Informationen über eine Datei oder einen Ordner: Datei- oder Ordnername, Größe, erste Cluster-Nummer und seine Attribute.


Datenverlust

Datenverlust entsteht dadurch, daß die Directory Einträge und/oder der FAT gelöscht worden sind oder fehlerhafte Informationen enthalten. Das Betriebssystem arbeitet bei einem Zugriff auf Dateien wie folgt: Daten aus Directory Eintrag lesen-> Daten im Datenbereich lesen-> FAT Informationen lesen und vorletzten Schritt wiederholen, bis die Datei vollständig gelesen wurde. Wenn die Directory Einträge und/oder FAT Einträge fehlerhaft bzw. gelöscht worden sind, kann das Betriebssystem die Datei jedoch nicht mehr lesen, obwohl diese sich noch im Datenbereich befindet. Aus diesem Grund meinen Anwender, ihre Daten wären verloren, in Wirklichkeit sind die Daten noch erhalten. Das Auffinden der Daten kann jedoch unter Umständen sehr aufwendig sein, da der gesamte Datenträger untersucht werden muß.

Datenverlust von Dateiinhalten
Daten sind vollständig verloren, wenn der Dateiinhalt beschädigt ist (also die Datei nicht durch fehlerhafte Informationen in FAT und Dateieinträgen verloren gegangen ist).

Dies könnte folgende Ursachen haben:

  1. Die Fesplatte/Diskette ist physikalisch beschädigt
  2. Viren oder Ähnliches haben die Daten zerstört
  3. Überschreiben von anderen Dateien haben dazu geführt, daß einige oder alle Cluster einer Datei geändert wurden. In diesem Fall kann nur noch ein Teil der Daten wiederhergestellt werden.


Gelöschte Daten

Gelöschte Dateien sind nicht wirklich gelöscht, sondern werden vom Betriebssystem einfach ignoriert. Wenn der Anwender eine Datei löscht (hiermit ist nicht das Verschieben in den Windows Papierkorb gemeint), wird der erste Buchstabe eines Directory Eintrages mit einem speziellen Zeichen versehen (es ist E5 hexadezimal - d.h. 229 dezimal). Weiter ist aber auch die Information über die Anordnung der Dateicluster beim Löschen entfernt worden. Das spielt insofern keine Rolle, wenn die Datei nicht fragmentiert war (d.h. die Cluster der Datei waren alle nacheinander abgespeichert). Bei fragmentierten Festplatten (dies entsteht durch häufiges Löschen und Kopieren) sehen die Chancen für eine Wiederherstellung relativ schlecht aus. Falls Sie jedoch die Datei unter Drive Rescue im Ordner "Deleted - gelöscht" sehen, können Sie eine Wiederherstellung probieren. Drive Rescue geht dann davon aus, daß die Datei nicht fragmentiert war.


Effektive Vorsorgemaßnahmen

Sie können die Chancen, Daten wiederherzustellen, erhöhen, wenn Sie einige Punkte beachten.

  1. Speichern Sie keine wichtigen Dateien im Wurzelverzeichnis ab.
    Dateien, die im Wurzelverzeichnis (root) abgespeichert werden, sind empfänglicher für einen Verlust durch Quick Formatierungen, weil dann Ordnereinträge im Wurzelverzeichnis abgelegt werden.
    Vermeiden Sie, Dateien direkt im Wurzelverzeichnis abzuspeichern, da die Datei verschwindet, wenn     der Verzeichnisentrag beschädigt ist. Im Notfall kann man Daten sehr schnell wiederherstellen, wenn sie sich in einem Unterordner befindet.

  2. Defragmentieren Sie regelmäßig die Festplatte
    Daten werden in aufeinanderfolgenden Clustern abgespeichert, wenn genügend zusammenhängender freier Speicherplatz zur Verfügung steht. Wiederholte Lösch- und Schreiboperationen fragmentieren das Laufwerk.

    Ein Beispiel:

    (1) (2) (3) (4) (5) (6) (7) (8) - sollen 8 kleine Dateien darstellen

     (1) (2) (3) (4) (5) (6) (7) (8) - jetzt wurden Dateien (2), (4), (7) und (8) gelöscht

    (1) (9) (3) (9) (5) (6) (9) (9) - Datenträger ist fragmentiert, wenn eine größere Datei gespeichert wird

    Wenn Daten vom Datenträger gelöscht werden, können neue Daten den freien Platz einnehmen. Wenn aber die neuen Daten größer als die alten sind, werden die Daten nicht in einem zusammenhängenden Bereich abgelegt, sondern in Fragmenten.
    Beim Lesen von fragmentierten Daten muß der Lesekopf der Festplatte "springen" (d.h. der Kopf wandert zu der gesuchten Spur). Dadurch kann die Lesen- und Schreibgeschwindigkeit herabgesetzt sein.
    Um den Lese-/Schreibvorgang wieder effizienter zu machen, ist es notwendig die fragmentierte Festplatte zu reorganisieren. Nach einer Defragmentierung sind die Daten wieder in sequentieller Reihenfolge und sehen dann so aus:

    (1) (9) (9) (9) (9) (3) (5) (6) - nachdem das Laufwerk defragmentiert wurde

    Eine gewöhnlich defragmentierte Festplatte wird die Effizienz einer Datenrettung verschlechtern, wenn z.B. der FAT durch ein QuickFormat oder einen Virus überschrieben wurde. Es ist dann notwendig genau zu analysieren, wie eine Datei über einen Datenträger verstreut liegt. Wenn aber zusammenhängende Daten vorliegen, ist eine Datenrettung anhand der Informationen über seine Position und Größe sehr schnell möglich.

    Wichtig: Ein Defragmentiertes Laufwerk wird, nach einer versehentlichen Löschung von Daten, die Wahrscheinlichkeit der Datenrettung sehr stark erhöhen, weil die Daten ab dem Cluster gespeichert sind, wo Ihre Daten beginnen.

  3. Speichern Sie keine wichtigen Daten auf Laufwerken mit geringer Kapazität
    Die Wahrscheinlichkeit der Wiederherstellung wird geringer, je kleiner die Speicherkapazität ist. Wichtige Daten sollten Sie auf einem freien Laufwerk sichern. Je kleiner die Kapazität ist, desto größer ist das Risiko einer Fragmentierung.

  4. Defragmentieren Sie Ihre Diskette, nachdem Daten auf dieser gespeichert wurden
    Disketten sind mit sehr hoher Wahrscheinlichkeit fragmentiert. Daher ist es ratsam bei wichtigen Daten, die Dateien in mehrere Verzeichnisse zu verteilen und dann die Diskette zu defragmentieren.

  5. Verwenden Sie kein Laufwerk, welches Sie zur Datenrettung benötigen.
    Installieren Sie keine Recovery Software auf einer Festplatte, welche Daten für Ihre Datenrettung enthält. Es könnten ansonsten Daten überschrieben werden und der Erfolg auf eine Datenrettung wird geringer. Vermeiden Sie jede Arbeit mit diesem Laufwerk und Speichern Sie dort keine Dateien. Verwenden Sie keine gewöhnlichen Programm, eingeschlossen den Windows Explorer, um nicht wichtige gelöschte Daten zu überschreiben.
    Für die Datenrettung sollten Sie ein zweites Laufwerk verwenden.


Contact form

Contact the author____________________________________________________
Your e-Mail:
Your country:

Languages you understand:

You have a question to / comment on the program:

if other, please specify:

 Version:
Your operating system: Supported languages:
Your hardware: CPU: Main memory:
Additional hardware you are using with the program: USB memory card reader
PCMCIA (PC-CARD) memory card reader
Digital camera:
ZIP or JAZ drive
other, please specify:

Your comments, suggestions, questions in english

Ihre Kommentare, Vorschläge, Fragen auf deutsch

Vos commentaires, suggestions, questions en français

Thanks for your message!