RCForb Server Setup
Overview

The RcForb Server allows you to setup your own remote station on Remote Hams. Three connections
to your transceiver are required, and an Internet connection.

The first required connection to your transceiver is is a CAT/CIV control. This is normally through a
Serial Port connection. This connection operates the transceivers controls, frequency control, mode
selection, filters, etc.

The next two connections are the audio connections to and from the transceiver and the computers
sound card. You need to get the receivers audio to a Windows Record device (Line In or Microphone
In) and a Windows Playback device to the radios Microphone Input. Some kind of audio isolation
transformer needs to be in line with the latter. Most sound card interfaces on the market have this
isolation transformer built in.

Some later model radios such as the Kenwood 590, Icom 7410,7600,7200, 9100, and Yaesu FTDX-
3000 have all three connections through a USB interface to the radio, but they will be presented in the
computer as three separate connections. One Serial Port connection and the other two as audio devices.

If you're interfacing the audio connections with an accessory port on your radio, depending on the radio
model and radio driver, you may need to have the Remote User use a button labeled “TXd.” to place
the radio into transmit and have the radio configured to utilize the accessory port for audio. Examples
are the Kenwood 590, Icom 7200,7600,9100, and 7410, and Yaesu FTDX-3000.

Some radios when using a “data” port for TX audio, the radio must also be keyed at the “data port” in
order for the audio to be passed correctly.

Most radio drivers will also have a “Test” button. When this button is active, the radio will not be
keyed up, but the VoIP will be rerouted so users may converse without keying the transmitter. If
External VOX Device (Signalink) is selected for PTT interface in Radio Configuration, the Test button
will not work.

Another common button in most radio drivers is “M-Tune”. This button will configure the radio to send
out a steady carrier at reduced power (time limited) in order for a automatic antenna tuner to tune.
(Kenwood radios the button is named TXt).

Three ports (4524,4525,843) will need to be forwarded on your router. Port 843 only needs to be
opened and forwarded for older Version 7 Clients to connect. When starting the server, the server will
look to see if your router ports can be automatically opened, and if so, will open the required ports.

If your router ports can't be opened automatically, you will need to manually open them. Consult your
routers documentation or go to http://portforward.com/ for information.

Typically a routers port forwarding will be found under Port Forwarding or Gaming and Applications.
There are basically three components of forwarding a port. First the “outside” port to listen to.
Secondly the local port the internet traffic will be sent to. These two ports will normally be the same.
Third the type of traffic (TCP/UDP). Forth the local computer the traffic is to be sent to. The computer,


http://portforward.com/

the traffic is to be sent to, will be specified as a local IP, or computer name, or MAC address.
On the publishing tab of the Server there is a button to check if the ports are opened properly.

When using the Client Software to test your server installation, there may be instances where you can
not connect to your own server through the Client List. This is due to network and router
configurations. If this is the case, use the “File->New Connection” in the Client and in the “Host/IP”
box, type the local IP address (i.e. 192.168.xxx.xxx) of server computer, or if using the same computer
use localhost for the Host/IP.

Another caveat when testing your server installation and using a Client on the same computer, you can
not use the same sound devices.

Changes to the Server or Radio configurations normally require a restart of the server software.
Configuration pages have a “Save and Restart” button.

Check the Remote Hams forums for other help http://forums.remotehams.com/


http://forums.remotehams.com/

Audio Setup

E :

| ValP Server

VOIP Port 4524 Wait T Audio Delay To Unkey
Microphone (R¥ Audio from Radio) Device Mode

| Monitor (M-Audio Delta 44) ~ | |DirectSound (Low Latency) |
Speakers (TX Audio to Radio) olP Codec (Compression

|Line 142 (M-Audio Detta 44) v | | Speex

Mic Level {(RX Audio Input)

Volume (TX Audio Output)

3rd Party Audio Solutions (Unreal Media Server, Slope, lcecast, etc )
Streaming Audio (FX Cnhy) Slype for Audio (RXTX)

Type [Disabled v] Skype Name

Clomain/Host wérjremnte.d.lii';kc-lﬂns_mm " Custom Stream URL
Server Port 5119 | Title of URL

Alizs/Mourt 2756 URL:

Close Save and Close [ Save and Restart J

VoIP Port : Leave Port, and wait to UnKey at defaults (Checked).
Microphone: Windows sound device that is connected to your receiver audio,
Speakers : Windows sound device that is connected to your transmitters Microphone Input.

Device Mode : Selects which Windows sound interface. Direct Sound offers a lower latency.

Mic Level : Sets the audio level for the record device (RX Audio)
Volume (TX Audio Output) : Sets the audio level for the record device (RX Audio)

3" Party Audio Solutions. : Used to setup an audio solution other than the built in VoIP.



Server Settings

rGIobai Server Configuration Wizard | Qs sErver.xn
| PIEERER A R
| Audio Settings || Server Settings || Publishing
| Radio Server Settings Basic Securty
Radio Server Port 4525 [ Require Login to Tune

[ Guests Mot Allowed

Enforce "Ask To Tune” Policy

[ Enforce "Wait To Tune" Policy
Tum T¥ off when user disconnects
Enable "Reserved Slot" System
TOT Timer (Seconds) 90

Syrto Restict Remate to (Club, T, Admin)

. Client Idle Timeout in Hours
HRD IP-Senver Emulation Ay setting below 1 hour

Emulate HRD Version ['u'5 T] will disabled the timeout.

|P-5erver Port (Default: 7809) 7805

Close Save and Close [ Save and Restart J

Radio Server Port : Leave as default.

Basic Security

Use these options to control who can log in and operate the radio. Transmit privileges are controlled
through the TX Manager and/or the Club Manager (Under the Options Menu)

HRD IP-Server Emulation.

Enable this option if you wish to use DM-780 or the HRD logbook through the server. DM-780 or the

HRD Logbook will use the Remote Hams server to control your radio and/or retrieve information about
your radio.



Publishing

Visible on RemoteHams= com

Name of Remote  WERJ South Lyon, Mi T Alowed ] Club Mode (Allow Club Members Cnly)

City South i_'_.fon | State or County Mi

Courntry -|:|-n'rted-5-t-;‘:ltes * Grd Square Er:lénz-d-l [ Lookup Grid Square ]

Domain {Optional) wSiremote dinkdd Custom ORB Page URL:
Description

Welcome the the WER. remote. Please download client software to transmit and recaive. TX
frequencies 3.7 to 4.0 Mhz and 14.150 Mhz to 14 300 Mhz only. | lost some information on users that
were given TX privledges after Jan €, please request TX again.

Save and Close || Save and Restart

This is information about your remote, that will be shown in the RcForb Clients list of remotes. Leave
the Domain entry blank, unless you have a domain name registered that resolves to your IP address.



Radio Configuration

Radio Configuration Wizard {Seﬁiﬁ sfradio.xml) ‘
; i

@ Full Remote Radio (CAT Controlable)
© Simplex / Repeater Link (PTT Only)
© Virtual Remote (Testing Purposes)

Choosing your Remate Type

Choose Full Remote:
If wour planning on setting up a CAT contrable radio allowing users to change frequency, etc.

Choose Simplex / Repeater Link:
If wou planning on setting up a PTT onby based remote for linking a simplex frequency or repeater.

[Canu:el ] [ Preview Corfig l [ Save and Restart J

Select the appropriate type of remote you're setting up.

1) CAT controllable is for radios that have a CAT/CIV interface to control frequency, mode, filters,
etc.

2) Simplex / Repeater Link is for remotes that will have a fixed a frequency and just a interface to to
control PTT on the radios through a Serial Port signal line (RTS or DTR).

3) Virtual Remote. Uses a dummy radio. Useful for testing whether you have your router and internet
connections setup correctly.



Radio Connection

Radio Configuration Wizard (Setti
E P i

Remote Type |: Radio Connection | PTT & CW Keying I Other Devices
Radio Connection Method
| i@ via Seral {COM) Port ) via Ham Radio Delxe ) via Shortwave Log

Seral {COM) Port Corfiguration Radia Driver Selection

COM51 v | Serial (COM) Port | Icom v| Bard ||}
|| 13200 > Seral Rate | 756_Proll v | Model
: 6E - :_ '.L_: 5 [7] Show Unstable Drivers
1| |[E DTR
I [ Use RTS Pinfor Power On [7] Power On Pin Reveresed?
|| E rrs
| Connection via Ham Radio Deluxe ave Log
[ e
| localhost Domain/Host
| [=nno -

7809 Part

|
|
|
[

[Cancel ] [ Preview Corfig ] [ Save and Restart ]

Via Serial Port : Select this option if your radio is CAT/CIV controllable, then select the Brand and
Model of radio. Also select the proper Serial Port and baud rate. For Icom radios select CI-V for model
and select the proper CIV address or type the CIV address in.

Via Ham Radio Deluxe: If RcForb doesn't have a driver for your radio and Ham Radio Deluxe
supports your radio, select this option. Ham Radio Deluxe needs to be running and connected to your
radio. Make sure HRD's IP server is enabled. (Tools->IP Server”)



PTT & CW Keying

[ Radio Configuration Wizard (Settings/radio.xmi) Z all

E—————eer

PTT Configuration :

PTT(TX) @ wia CAT
- wia COM Lea RTS Cycle P On Stan
7 wia VOX

VA i - - J
M1 Llze OTR Reverse Polanty

Externial TV Kesving Edemal CW COM) Port Corfiguration
CW KEY) @ Enabled  ©COM)Port [COM8 /| OnCW: (] Use DTR || Reverse Polarty
[esabled | Use ATS  [] Cycle Fin On Start

F your radio doeg not suppoet PTT owver CAT, you may utlize 3 senal [COM) pont for PTT using 2 devece such
as @ RiGblaster or Custom PTT Interface by switching the DTR or RTS sgnals

To e the Sesinl (COM) Part with your FTT Interface:

Select the Seral (COM) port, this pon must not be in use by anather program
Select the ping to sgnal (DTR. BTS or DTR and RTS) for activating PTT

i neadad you can reverse the palanty of the signal,

|'_'||Eﬂ_:: '_Thls port cannot be used by another program such as HRD -2 must be available for exclusive use by

| Cancel | | Preview Canfig | | Save and Restat

PTT Configuration

Via Cat : If you want to use a CAT/CIV command to control your radios PTT.

Via Com Port if your station setup requires a Serial Port line (RTS/DTR) to control a sound card
interface with a signal line. This com port may be the same as the CAT Serial Port if the sound card
interface supports this serial port configuration.

Via VOX (SignaLink or similar). If you have an interface unit that keys the radio, when it senses audio.

External CW Keying

This selection enables CW operations using a simple interface on a serial port acting as a switch on the
DTR pin of the port driving a simple NPN transistor switch to open and close the manual keying circuit
on your transceiver. Use a stereo jack, and wire the tip and sleeve, leave ring unconnected.

* Keying Circuit. FPin numbers for DB-9
2135904 (General Purpose NPHM)

DTR (Pin 4) ——"y L
1K

B

To Manual Key Jack on Radio

Ground (Pin §) Sleeve



Other Devices

Radio Configuration Wizard I[Settingsfradiomll ‘
| Remote Type. | Radio Connection | PTT & CW Keying |} Diher Bevices |

Amp Support Switch Support (Relay Boards) Raotator Suppaort

[ Amplifier Enabled [ Switch Enabled [ Retator Enabled

[ v | Select Driver | ADR2200 v | Select Driver | AlphaSpidRAK v | Sslect Driver

33400 w» Seral Rate 5600 w» Seral Rate 4300 w» Seral Rate

CoM1 » | Seral (COM) Port CoM1 = | Seral (COM) Port CoM1 » | Seral (COM) Port

[] Auto-Track Radio Frequency . Custom Names . . Offset
* Comma Separated List = Cffset must be in range (-180to 180)

BEx: ANT1 ANT2 ANT3 . AMP [Leave blank for default)
(Leave blank to use default names)

[Canv:el ] [ Preview Config ] [ Save and Restart J

Select the proper baud rate and COM port for an Amplifier, Switch or Rotator.

Custom Names (Switch): Insert a list of custom names ( Comma separated list) for the switches that
will be displayed on the Client software (V8 of Client required).

i.e ANT1,ANT2,ANT3,ANT4,AMP First four relays name ANT1 ANT2 ANT 3 ANT4 and 5th
named AMP.

First 4 switches are mutually exclusive, while switches 5 to 8 are independent. If no switch 1 to 4 is
selected, the first switch will be closed.

Rotator Offset: Insert any offset needed for your rotator (-180 to 180 )

Permissions for access to these devices may be restricted through the “Device Permissions Manager”,
found under the Options menu.



Simplex / Repeater Info (Available only if Simplex / Repeater Remote Type selected)

Radio Configuration Wizard (Settings/radio.xml)

| Remote Type | Radio Connection | PTT Inteface | Simplex / Repeater Link Infa ; Hntatnrl

fio Mode! |Enter model... + | Freq Pref |'.,.'||-|E =

RX Freq [442 775

Tone/DCS [110.9 Hz

This information is used when settings up a simplex or repeater link.
You may specifiy the model of your radio or just the brand name.

You can specifiy the pareed frequency of your linke when in RX and TX, the Mode, and any
PL Tone or OCS code used on frequency.

[Cancel ] [ Save and Restart ]

If you used the used the Simplex / Repeater Link option, enter the desired information about your radio
that will be displayed to a remote user.



Security Manager (Under Options->Security Manager)

Global Security Manager -‘.

I Alowed RX Frequencies 500000-60000000 [] Enabled B

Allowed TX Frequencies 3500000-4000000,14000000-14350000.70 [¥] Enabled [ .. |
Blocked Frequencies 26565000-27405000, 755000- 765000

Blocked Featurss H'I'I'Y,HTI'Y—H.FM

Allowed Buttons T Tune,PB Cir,NE NR ANF,MNF Stop mmz]
Alowed Dropdowns Ty Mir Mode, Fitter AGC, Pre Amp ATT.CW mmg
Allowed Sliders NR Level PBT Outside, PBT Inside, BK-IN Delay [_None |[ Get List |[ ... |
Alowed Messages Faults Elements, CW @@|D
Alowed Statuses Main VFO,5ub VFO [ None [ Get List J[ ... |

)

[] Disable Remote on Local Radio Activity Disabled Duration (Seconds) |300 =
[ Enable User Level Pemission for Other Devices {Amp, Rotator, Switch, etc.)

* ADMINs BYPASS ALL SECURITY,
only assign yourself as admin.

I Import l[ Export l[ Cancel

Allowed and Blocked Frequencies : Clicking on the small button with 3 dots will open a dialog box
where you can input in blocked or allowed frequencies. Be careful to select the proper format of
frequencies entered, i.e. Hertz, KHz, or MHz.

Blocked Features: You may block certain controls, even an item in a drop down, with this feature
Allowed Buttons, Dropdowns, Sliders, Messages and Statuses :

Click “None” if you wish to not display any controls in the group.

Click “Get List” to populate the respective group of controls. Click the small button with 3 dots to the
right of the “Get List” to Add/Remove and order the respective control group.

You must log out and log back in on the client, to see the above changes.

As radio drivers are updated by Remote Hams or changing radio's, you may need to use the “Get List”
button, if the radio driver has added a new control.

Fhkkdkkkdk* Administrators bypass all security features ***¥*%%*



Example of Allowed Controls (Controls to be displayed on Client).

s

Select Buttons to Allow

Selected tems

Tune
NR
NEB
PB CIr
ANF
MMNF

Double-Click to Remove

<< Move Up

< Add

Remaove =x

<= Move Down

™

Available

T¥d
ATU
Man
oW
Split
Main
Sub
M5
M=5
Comp
Tone
TSAL
Lock

»

m

Double-Click to Add

| Cancel | | Update |

Move Up / Move Down: Change the order in which the controls are displayed on the Client.

Add/Remove: Add and remove controls from displaying on the Client.

In the example above the controls listed on the left will be displayed in a client in the order they are

listed.

Changes will not be displayed in the client, until the client is disconnected and reconnected.



