Introduction

The NMEA SA for hC2 PATROL provides the ability for supported applications to utilize National Marine Electronics Association (NMEA) formatted Situational Awareness (SA) reports from supported L3Harris radios. NMEA SA reports can provide hC2 PATROL nodes, or supported applications, a position that can be distributed across the Common Operating Picture (COP).

A printable PDF document of this Help content is also provided. Users must have Adobe Reader DC installed to view the PDF version.

All acronyms used in the Help are defined in the Glossary.

A software license is required to operate this program.

Reference

This information is intended for personnel who are going to configure and deploy the NMEA SA for hC2 PATROL using the hC2 Management Tool. Use of the Management Tool is described in the following manuals.

hC2 PATROL and DISMOUNT Administrator Manual, 10515-0479-4200


Compatibility

The following lists the supported operating systems, hardware, applications, and L3Harris radios.

Supported Operating Systems

The software is compatible with the following Operating Systems.

  • Windows 7 (32-bit/64-bit)

  • Windows 8.1 (32-bit/64-bit)

  • Windows 10 (32-bit/64-bit)

  • Windows Server 2008 R2 (64-bit)

  • Windows Server 2012 R2 (64-bit)

  • Windows Server 2016 (64-bit)

  • Windows Server 2019 (64-bit)

The Latest Service Pack is recommended.

Minimum and Recommended Hardware

The software is minimally supported on PC hardware that meets the following requirements:

  • 4 GB RAM

  • Intel i7 U620 @ 1.0 GHz Core Duo or better

  • 10 GB SSD or better

  • PC monitor resolution of 1024 x 768 or better

The software is suggested to run on PC hardware with the following requirements:

  • 8 GB RAM

  • Intel Core i3-6100T or better

  • 80 GB SSD or better

  • PC monitor resolution of 1280 x 1024 or better

  • PC with a 512 MB Dedicated Video Memory with supported Open GL 2.0

Supported Applications

The software is compatible with the following applications.

  • hC2 PATROL 3.4 (hC2 Management Tool)

  • Systematic SitaWare Frontline 3.4 (SitaWare Management Tool)

The L3Harris License Manager 1.4 is included with the software package to monitor the status of any installed L3Harris software licenses.

Supported Radios

The following L3Harris radios are supported by the NMEA SA for hC2 PATROL when configured appropriately.

  • RF-7800W-OU47x (Firmware 6.0 or newer)

  • RF-7800W-OU50x (Firmware 6.0 or newer)

  • RF-7800W-RP47x (Firmware 6.0 or newer)

  • RF-7800W-RP50x (Firmware 6.0 or newer)

  • RF-7850W-OU47x (Firmware 6.02 or newer; 50.00 or newer)

  • RF-7850W-OU50x (Firmware 6.02 or newer; 50.00 or newer)

  • RF-7850W-RP47x (Firmware 6.02 or newer; 50.00 or newer)

  • RF-7850W-RP50x (Firmware 6.02 or newer; 50.00 or newer)

NOTE: The x following each model name signifies a color code.


Installation

Installation Overview

The NMEA SA for hC2 PATROL software is installed using the add-on approach for supported applications. The software is loaded into the Management Tool. Once installed, the Management Tool will provide the ability to configure NMEA SA for the specified Platform deployment. It is not possible to install NMEA SA directly into a deployed Platform.

Information on how the add-on is installed in the Management Tool is described in the Preparation > Add-ons section in the administrator manual.

  • Add-ons are installed using the File > Add-ons dialog.

  • The driver file, NMEA SA-3.4.smt, must be present for installation.

  • After the add-on has been unpacked successfully, the hC2 Management Tool must be restarted to complete the installation.

Installation Steps

  1. From the L3HarrisAutoStart.exe, select Software and then select NMEA SA for hC2 PATROL 3.4. This displays the NMEA SA-3.4.smt file which will be needed for the remaining steps.

  2. Launch the Management Tool and go to File > Addons...

  3. On the dialog box, select on Add New and navigate to the folder that contains the SMT file.

  4. Check on the Add-ons and select OK.

  5. The Management Tool will start unpacking the files. After it is done, it will tell the user that it needs to restart the application in order to use the add-on that was just incorporated into the system.

  6. When you relaunch the Management Tool, it will take a couple of minutes to install the add-on. Once complete, the software is now installed into the Management Tool.

NOTE - Removal of the NMEA SA plugin from the Management Tool is not possible once installed. Once installed, the NMEA SA software only functions when sensor configurations for a Platform deployment is defined. By default, the software is disabled in all Platform deployments.


Software License

This application uses a L3Harris licensing subsystem to determine whether the application can run successfully on a PC. The L3Harris License Manager, or the Status area of an Application deployment, can be used to check the status of this license.

For detailed information about the NMEA SA license, run the "L3Harris License Manager". The L3Harris License Manager is available as a separate install on the NMEA SA media, or click the Status button in the top bar of an application deployment, and navigate to the System Installed Licenses section.

When the NMEA SA installed license is no longer valid, the NMEA SA feature will no longer process received formatted SA reports from supported devices.

Install L3Harris License

L3Harris licenses can only be created by L3Harris. When L3Harris sends the license to a customer, the customer must install the license on the PC that it is licensed to run on.

NOTE: The L3Harris License Manager will need to be installed on each machine that will utilize a licensed product.

  1. Open the L3Harris License Manager on the desired machine.

  2. Select the Install option.

  3. Navigate to the location of the L3Harris provided license.

  4. Select the license and click OK.

  5. Observe, once installed, the license status will display in the License Manager.

Uninstall L3Harris License

  1. Open the L3Harris License Manager on the desired machine.

  2. Select the license that should be uninstalled.

  3. Select the Uninstall option.

  4. Observe the License Manager will remove the selected license.


Configuration

The NMEA SA for hC2 PATROL is configured as a sensor configuration for Platform deployments using the Management Tool. A NMEA SA sensor configuration will need to be defined for each Platform deployment that will use NMEA SA reports for local position, or to report the position of friendly units received by the deployment via the connected radio to the rest of the network.

General

Each platform can provide 0, 1 or more NMEA SA sensor configurations; however, generally only one (1) is necessary when a connected and supported radio is supplying the position of the hC2 PATROL node. When multiple NMEA SA configurations are specified, each configuration must define a unique source IP and radio name. A single configuration can receive NMEA SA reports from a single L3Harris radio. Only platforms that will interface directly with L3Harris radios need to have a sensor configured. Once the SA report is received from a single L3Harris radio, it can be relayed to the rest of the network, based on system configuration and connectivity.

Friendly unit positions may persist on the COP after they expire and will be removed after 6 hours of inactivity, and the symbol may turn gray.

When a platform is configured with one (1) or more NMEA SA sensor configurations and none of the sensors are configured as "Own Station", ensure that the PC time is synchronized by a Network Time Provider or similar service.

Settings

The following settings can be configured for each NMEA SA configuration in the Management Tool.

Type (For informational purposes only) - “NMEA SA - UDP”

Category (For informational purposes only) - “Track Provider”

Name - A user-specified name for the NMEA SA configuration. For informational purposes only.

Track Provider - Determines if the NMEA SA configuration will be active in the deployment, when more than one NMEA SA sensor configuration is defined. Enabled when checked. Default is checked.

Own Position - Determines if the NMEA SA will provide the Platforms’ position. Enabled when checked. Default is unchecked. When checked, the reports coming from the Source IP are considered to be providing position information that represents the Platform. If a single platform has more than one NMEA SA sensor configuration, only one configuration should be selected as the Own Position value for the source of SA reports, thereby avoiding conflicts.

Port - The port number that the NMEA SA configuration will use to listen for reports. Default is 10110.

Own Position Timeout (seconds) - Determines the amount of time in seconds that the GPS coordinates of the own COP symbol are considered to be valid. Default is 20 seconds. The value can range from 1 to 65535 seconds. PC/radio time synchronization and potential network latency issues should be considered when deciding on an appropriate Own Position Timeout value (seconds).

Radio Name - Defines the name that represents the reporting station. Unicode characters are valid, except for the following special characters: !, #, \, >, =, ;, :, /, *, |, ^, ?, <, Con, Prn, Aux, Nul, Com[1-9], and Lpr[1-9] . Radio Names are restricted to be between 3 characters in length and 40 characters in length, inclusive. Default is empty. If a single platform has more than one NMEA SA sensor configuration, each configuration should use a unique Radio Name value for the source of SA reports, thereby avoiding conflicts.

Source IP - Defines the IP address that represents the reporting unit. Source IP is restricted to a single IP address. The default is empty, but the Source IP is a required setting. If a single platform has more than one NMEA SA sensor configuration, each configuration should use a unique source IP value for the source of SA reports, thereby avoiding conflicts.

Setup NMEA SA Software for a PATROL Platform Deployment

To configure NMEA SA sensors for Platform deployments, create a platform deployment following the hC2 PATROL and DISMOUNT Administrator manual (10515-0479-4200). Then perform the following.

  1. From the Platforms tab, select the platform that should provide a NMEA SA configuration.

  2. Select Sensors.

  3. From the Sensors view, select Add Sensor.

  4. Place a check in the Select column to the right of NMEA SA - UDP.

NOTE - You can hover over with your mouse to view a more detailed description of the sensor properties.

  5. Configure the properties as necessary, then press OK.

  6. Press OK again to exit the sensors view.

NOTE - Select Validate to make sure the configuration is valid prior to deployment.

  7. Follow the procedures defined in the PATROL and DISMOUNT Administrator Manual (10515-0479-4200) to create Platform and Application deployments.

NOTE - The following section explains a future feature, not available in the current 3.4 release.

Setup NMEA SA Software for a PATROL Application Deployment

To configure NMEA SA software for Application deployments, create an application deployment following the hC2 PATROL and DISMOUNT Administrator Manual (10515-0479-4200). Then perform the following:

  1. From the Applications tab, in the Properties section, select Show Advanced Properties.

  2. Find the FFT Timeout in minutes property.

  3. Set the FFT Timeout in minutes to an appropriate value.

NOTE: This property controls the timeout for all Friendly Force / External Tracks in all add-on sensors in the same application deployment, regardless of type of sensor. Choose the value carefully considering all add-ons in the deployment.

  4. Configure any other application properties as necessary and select Validate to ensure a valid configuration.

  5. Continue to follow the procedures defined in the PATROL and DISMOUNT Administrator Manual (10515-0479-4200) to create Application deployments.


Operation

Once the Platform software is installed and running, the NMEA SA software is ready to process packets received from supported devices, if configured.

  • If you have devices that represent your station, make sure you have configured them to provide SA reports in NMEA format to the system running the Platform. Refer to the radio user manual for more information on how to configure its Situational Awareness settings.

  • When a report is received, it will either update the Platform position (where valid) or the position of an external track symbol on the COP.

  • Staleness of the Platform position is determined by the Own Position Timeout (seconds) configuration option for the sending device; and own position expiration/removal from the COP occurs at about 30 seconds after being stale.

  • The expiration/removal of the external dot from the COP will occur at about 6 hours after the last report for the track.

  • FUTURE: Staleness of the external tracks are determined by the FFT Timeout in minutes application configuration option.


Glossary

-C-

CM | Control Module
COP | Common Operating Picture

-E-

EAR | Export Administration Regulations - EAR99 is a classification for an item. It indicates that a particular item is subject to the EAR, but not listed with a specific ECCN on the Commerce Control List.
ECCN | Export Control Classification Number

-G-

GB | Gigabyte
GHz | Gigahertz
GPS | Global Positioning System

-H-

hC2

L3Harris Command and Control

-I-

ID

Identification

-N-

NMEA

National Marine Electronics Association

-P-

PC

Personal Computer

-R-

RAM | Random Access Memory
RF | Radio Frequency

-S-

SA

Situational Awareness

-U-

UDP | User Datagram Protocol - a minimal message-oriented transport layer protocol.
U.S. | United States


About This Help

REFERENCE Number: 10515-0479-5015
MARCH 2023
REV. G

NMEA SA for hC2 PATROL

RF-7800N-BM690

This information/part is controlled by the U.S. Department of Commerce Export Administration Regulations 15 CFR 730-774, ECCN EAR99.

Information and descriptions contained herein are the property of L3Harris Technologies, Inc. Such information and descriptions may not be copied or reproduced by any means, or disseminated or distributed without the express prior written permission of L3Harris Technologies, Communication Systems, 1680 University Avenue, Rochester, New York 14610-1887.

Copyright 2023
By L3Harris Technologies, Inc.
All Rights Reserved

This Help is based on v3.4 of the NMEA SA for hC2 PATROL.

L3HARRIS TECHNOLOGIES INC. COMMUNICATION SYSTEMS

1680 University Avenue Rochester, New York 14610-1887 USA

Tel: 585-244-5830. Fax: 585-242-4755. http://www.L3Harris.com