Introduction

The L3Harris Situational Awareness (SA) Module Add-on, RF-7800N-BM310, is a position driver for hC2 PATROL and hC2 DISMOUNT. The information in this document is intended to help in configuring and deploying the ITAR Position driver using the hC2 Management Tool.

The following functionality is provided as part of this add-on:

  • Situational Awareness (SA): The L3Harris SA driver is able to receive SA data from connected L3Harris radios and distribute them as Friendly Force Tracks across the Tactical Communication network.

  • Own Position: The L3Harris SA driver is able to report a specified SA track as its own position, to be used in hC2 Patrol or hC2 Dismount and distributed across the Tactical Communication network.

  • External Tracks: The L3Harris SA driver is able to report SA tracks for friendly forces, to be used in the Common Operational Picture and distributed across the Tactical Communication network.

Reference

Refer to the hC2 PATROL and DISMOUNT Administrator Manual (10515-0479-4200) or hC2 DISMOUNT Administrator Manual (10515-0480-4200) for use of the Management Tool. Refer to the hC2 PATROL Release Notes, 10515-0479-4110, for hardware requirements.

Select this link to open an Acrobat Reader output of this document.

Position Driver Description

The L3Harris SA Module integrates L3Harris radios-delivered SA information (positions of radios in the same network) into Tactical Communication. From there, they are distributed over the tactical network to other hC2 installations and can be displayed in other hC2 installations. The information can also be used to update the designated own position and time in hC2.

When the driver has been successfully configured, external radio positions reported by L3Harris radios are used as own position or external tracks, inserted and updated in Tactical Communication. This means that the radio positions are viewable in hC2 COMMAND, PATROL, and DISMOUNT as either own position or friendly force tracks.

The radio name/id will be used as “Call Sign” of the track.

It is possible to use this add-on in conjunction with the hC2 PATROL feature Track Aggregation Console which makes it possible to rename and define two radio position inputs as the same track.

Supported Products

This add-on can be used in the following products:

hC2™ PATROL v3.4

hC2™ DISMOUNT v3.4

SitaWare Frontline v3.4

SitaWare Edge v3.4


Configuration

The position driver can be added and configured for a platform using the Sensors Dialog in the Management Tool.

Local Radio Station Names

The Local Radio Station Names field is required when Own Position is selected. Though the software allows an empty field to be successfully validated, the result in the deployed PATROL/platform will be to display only external tracks. To remedy this situation, ensure that the Local Radio Station Names field contains at least one name when defining an Own Position sensor.

Auto Selection of COM Port

The position driver can be configured to automatically select a COM port when using the ‘Harris SA – COM’ sensor type. This is done by typing ‘Auto’ in the ‘Port Name’ field. When the position driver is set up to auto select a COM port, it will look in the Windows registry and fetch all the port names defined with the following key:

SYSTEM\CurrentControlSet\Enum\usbcdcacm\Vid_19a5&Pid_0012&MI_02\<radioKey>\Device Parameters

From that list of COM port names, it will then use the first port that is available.

Radios with PPP Connection

This section only applies to the following radio models:

  • RF-7800H-MP (Firmware 2.0 or later)

  • AN/PRC-160 (Firmware 2.0 or later)

  • RF-5800H-MP (Firmware 1.7 or later)

  • AN/PRC-150(C) (Firmware 1.7 or later)

The Platform must be configured with ‘Harris – UDP’ and the PPP connection between the PC with Tactical Communication and the L3Harris radio must be established and connected. This can be done using the L3Harris Network Radio Driver Installer (NRDI).

Notice that the configuration of baud rates in the NRDI driver must match the configuration in the radios.

Once the PPP link has been established (but not connected), you must also “dial up” the radio to establish the connection between the PC and the radio. If the connection is interrupted by preset page changes to the radio, entering the programming menu, hardware failures or other ways, then the connection is lost without a warning, and the user must “dial up” the radio again to re-establish the connection.

Firewall settings must not prevent the data packages from the radio to reach Tactical Communication.

Prerequisites

The radios must have the SA Packet Type set to “HARRIS” or "International" (other formats are not supported). See the Situational Awareness section of the individual radio manual for details on how to set the Packet Type.

RF-7800S Radio

When using the L3Harris Position Driver with one or more RF-7800S radios, the hC2 PATROL Vehicle Platform must be configured with ‘Harris – COM’ and the hC2 DISMOUNT platform with ‘Harris – USB’.

Accept Input from Single Radio

The Position driver can be configured to only accept input from a specific radio when using the 'Harris SA - UDP' sensor type. This is done by typing the IP of the radio in the 'Local Radio IP' field. When the 'Local Radio IP" field is set, the driver will discard all input from other radio sources.


Compatibility

This add-on is generally compatible with L3Harris Falcon II, III, and IV radios providing SA functionality. Due to variations in the firmware versions on different radios, tests should be performed on the specific version of the radio to be used before general deployment.

This driver has been tested with the following radio models:

  • RF-7850M-HH

  • RF-7825M-HH

  • RF-7850V-HH

  • RF-7825V-HH

  • RF-7850S

  • RF-7850A

  • RF-7850D

  • RF-7800M-MP

  • RF-7800M-HH

  • RF-310M-HH

  • AN/PRC-152A

  • AN/PRC-117G

  • AN/PRC-160

  • AN/PRC-158

  • AN/PRC-159

  • RF-7800H-MP

  • AN/PRC-150(C)

  • RF-7800S

  • AN/PRC-163

  • AN/PRC-167

Other L3Harris radio models will likely also work with this driver for Tactical Communication as they use the same formatted messages. When using the L3Harris SA driver with hC2 DISMOUNT on a L3Harris tablet, be sure to have “Maintenance Mode” disabled from system settings. If the mode is disabled while the system is active, reboot the device after disabling to ensure a connection to connected radios.


About This Help

REFERENCE Number: 10515-0479-5011
MAY 2023
Rev J

L3Harris SA Module Add-on

RF-7800N-BM310

This information/part is controlled by the U.S. Department of State International Traffic In Arms Regulations (ITAR), 22CFR 120-130, and cannot be exported from the United States or shared with a foreign person without prior approval from the United States Government.

Information and descriptions contained herein are the property of L3Harris Technologies. Such information and descriptions may not be copied or reproduced by any means, or disseminated or distributed without the express prior written permission of L3Harris Technologies, Communication Systems, 1680 University Avenue, Rochester, New York 14610-1887.

Copyright 2023
By L3Harris Technologies, Inc.
All Rights Reserved

This Help is based on v3.4 of the L3Harris SA Module Add-on.

L3HARRIS TECHNOLOGIES INC. COMMUNICATION SYSTEMS

1680 University Avenue Rochester, New York 14610-1887 USA

Tel: 585-244-5830. Fax: 585-242-4755. http://www.L3Harris.com