Introduction

The Harris International IP Add-on, RF-7800N-BM330, provides a network type that optimizes hC2 data transfers over supported radios. A subnet identifier configuration is introduced with this version 2.2 release. In addition, this release allows hC2 PATROL to be part of multiple Harris 7850M networks while sharing the SNMP local port.

A printable PDF document of this Help content is also provided. Users must have Adobe Reader DC installed to view the PDF version.

All acronyms used in the Help are defined in the Glossary.

A software license is required to operate this program.

Reference

This information is intended for personnel who are going to configure and deploy the Harris International IP Add-on using the hC2 Management Tool. Refer to in the hC2 PATROL Administrator Manual, 10515-0479-4250, for supported operating systems, hardware, and applications. Refer to the hC2 PATROL Technical Data, 10515-0479-4020, or hC2 PATROL Release Notes, 10515-0479-4110, for hardware requirements.


Supported Radios

Supported Radios and Waveforms

The following Harris radios are supported by the Harris International IP Add-on when configured appropriately.

  • RF-7800V-HH and RF-7800V-V51x (Firmware version 4.5 or newer)

  • RF-7850M-HH and RF-7850M-V51x (Firmware version 4.5 or newer)

  • RF-7850A-MR (Firmware version 4.5 or newer)

  • RF-7850A-UA (Firmware version 4.5 or newer)

The following Harris waveforms are supported by the Harris International IP Add-on when configured appropriately.

  • TNW75 (75Khz bandwidth)

  • TNW25 (25Khz bandwidth)

  • M-TNW


Installation

Installation Overview

The Harris International IP Add-on is installed using the add-on approach for supported applications. The software is loaded into the Management Tool. Once installed, the Management Tool will provide the ability to configure Harris 7850M Network types for the specified Platform deployment. It is not possible to install the Harris International IP Add-on directly into a deployed Platform.

Information on how the add-on is installed in the Management Tool is described in the Preparation > Add-ons section in the administrator manual.

  • Add-ons are installed using the File > Add-ons dialog.

  • The driver file, Harris International IP 2.2.smt, must be present for installation.

  • After the add-on has been unpacked successfully, the hC2 Management Tool must be restarted in order to complete the installation.

Installation Steps

  1. From the HarrisAutoStart.exe, select Software and then select Harris International IP Add-on 2.2. This displays the Harris International IP-2.2.smt file which will be needed for the remaining steps.

  2. Launch the management tool and go to File > Addons...

  3. On the dialog box, select on Add New and navigate to the folder that contains the SMT file.

  4. Check on the Add-ons and select OK.

  5. The management tool will start unpacking the files. After it is done, it will tell the user that it needs to restart the application in order to use the add-on that was just incorporated into the system.

  6. When you relaunch the management tool, it will take a couple of minutes to install the add-on. Once complete, the software is now installed into the Management Tool.

NOTE - Removal of the Harris International IP plugin from the Management Tool is not possible once installed. Once installed, the Harris International IP software only functions when a configuration for a Platform deployment is defined. By default, the software is disabled in all Platform deployments.


Software License

The Harris International IP Add-on is controlled by a license. The license used to operate the Management Tool and create Platform deployments must support Harris International IP with the following entry "<harris-7850m/>" in the license.xml. The license.xml provided by Harris must be used to install, configure and operate the Harris International IP driver.

Install License

Appropriate licenses can only be provided. When Harris sends the license to a customer, the customer must install the license on the PC running the hC2 Management Tool.

  1. Locate the "hC2 Management Tool" used to configure and create hC2 deployments.

  2. Navigate to "server\etc\license" in the same directory as the "hC2 Management Tool Launcher.exe".

  3. Install the Harris provided license.

  4. Open the "hC2 Management Tool Launcher.exe".


Configuration

The Harris International IP Add-on is configured using a specialized Network type for Platform deployments using the Management Tool. All Platform deployments that will connect to a supported radio must be a member of a "Harris 7850M Network" in order to make use of the advanced capabilities provided by the Harris International IP driver. A Harris 7850M Network must be configured for all platforms to use.

The Harris International IP driver throttles the internal data transmission based on feedback from the radio. The TDMA throttling strategy works with TNW-25, TNW-75, and M-TNW

NOTE: Throttling is dynamically determined between radio and driver. A radio should not be connected to hC2 while sitting on a preset for a waveform that is not supported.

Throttling is fully dynamic and adapts to signal conditions as long as the "Automatic Configuration" option is enabled in the driver.

General

One or more Harris 7850M Networks may need to be configured and associated with Platforms based on network topology. The Harris 7850M Network type uses multicast IP communication to exchange data between hC2 nodes over supported radios. The member radios must be configured to support the multicast group defined in the Harris 7850M Network(s).

Settings

The following settings can be configured for each Harris 7850M Network in the Management Tool.

Name - Information name only for the Harris 7850M Network.

MTU Size - The Maximum packet size used by hC2 Tactical Communication in this network. (Default 500 bytes).

Port - Defines the port on which data is communicated in the network. (Default 23330). When connecting multiple networks to a single Platform, the port and multicast address must both be different.

Multicast Group IP - Defines the address of the multicast group to join. (Default 224.0.5.1).

SNMP Port - The port for sending SNMP requests to the Radio (Default 161).

Min Wait Time Between Bursts (ms) - Minimum time between each data transmission on the radio. (Default 1000 millisecond). This is a static parameter. When the option "Automatic Configuration" is not checked, this is the time between data bursts from the platform to the radio network. When the option "Automatic Configuration" is checked, this is ignored.

Max Data in Burst (Bytes) - The maximum amount of data sent in one burst (in Bytes). (Default 3000 Bytes). Max Data In Burst is ignored when "Enable Automatic Configuration" is checked.

Buffer Check Rate (ms) (min. 100) - The interval, in milliseconds, the adapter polls the radio's SNMP interface for the amount of data queued in the outgoing buffer. (Default 1000 milliseconds). If automatic configuration is enabled, the primary mechanism for throttling data is based on notifications, received from the radio, indicating when the buffer is about to deplete. In this case polling acts only as a fall back mechanism. If automatic configuration is disabled, polling is the only throttling mechanism.

Time to Live (Hop Limit) - Defines how many hops a multicast packet will survive in the network. (Default 3 hops).

Local Radio Interface - Local IP Address. Each member platform will specify a connected radio IP address using this as a starting point. (Default 192.168.0.1).

Subnet Identifier - Default Subnet Identifier IP Address. (Default 192.168.10.0/24). This parameter must be filled out. It needs to specify the network subnet on the Platform PC on which the radio is plugged into. This can be a subnet range that does not include the radio's IP address when routing is used to reach the radio.

Round Trip Factor - Defines the factor to apply to the estimated round trip time. (Default 10). This factor defines a ratio of link speeds and determines how fast file segments should be sent and acknowledged on the network.

Link State Nodes Expiry Time in Seconds - Defines the time in seconds that represents the expiration of Link State Nodes. (Default 0)

Always Use Multicast - When not checked, use unicast. When checked, all IP communication will always use multicast addressing, including file transfers.

Enable Automatic Configuration - When checked, the radio driver will query the necessary parameter from the radio to optimize data flow on the network, achieving high throughput and low latency. This option should be enabled for supported waveforms.

Sync Rate In Seconds - Defines how often sync messages are sent, per platform per gossip network DCS (distributed compressed sensing) in the subnet.

FFT Latency in Seconds - Defines the configured value for extra latency of all flooding DCS (distributed compressed sensing) in the subnet.

Maximum File Size (kB) - Defines the maximum size for files in sent in this network.

Add Local SNMP Trap Port - Port used for listening for SNMP traps. SNMP Traps are asynchronous notifications.

Setup Harris 7850M Network for a PATROL Platform Deployment

Perform the following steps to configure the Harris 7850M Network for Platform deployments. Next, create a platform deployment following the hC2 PATROL Administrator manual.

  1. Select "Add Network" from the Networks tab.

  2. Change the Type to "Harris 7850M Network".

  3. Enter a Name to identify this network.

  4. Select the newly created network (according to the name specified when multiple network configurations exist).

  5. Review and specify all necessary Network Properties.
    NOTE: Defaults may be sufficient for more purposes other than the Multicast Group IP that will need to correspond to the Radio's configured abilities.

  6. Select the Platform's Tab.

  7. Define two or more Platforms to be members of the Harris 7850M Network by selecting "Add Platform".
    NOTE: Refer to hC2 PATROL Administrator manual for instructions on defining a Platform deployment.

  8. Select the created platform.

  9. Select "Network Connections".

  10. Select "Add Network".

  11. Select the checkbox next to the desired Harris 7850M Network.

  12. Select OK.

  13. Change the "Local Radio Interface" to the IP address of the Radio that will be connected to the selected Platform.

  14. User must fill in the subnet identifier so that it describes the network interface on the platform PC that should be used to reach the radio.

  15. Select OK.

  16. Perform steps eight (8) through 14 for each Platform that is to be a member of the Harris 7850M Network.


Operation

Once the Network is defined, all member platforms have been deployed and the properly configured radios have been connected, the hC2 system is ready to exchange all supported information. No additional user intervention is necessary.


About This Help

REFERENCE Number: 10515-0479-5016
JANUARY 2019
Rev A

Harris International IP Add-on

RF-7800N-BM330

This information/part is controlled by the U.S. Department of State International Traffic In Arms Regulations (ITAR), 22CFR 120-130, and cannot be exported from the United States or shared with a foreign person without prior approval from the United States Government.

Information and descriptions contained herein are the property of Harris Corporation. Such information and descriptions may not be copied or reproduced by any means, or disseminated or distributed without the express prior written permission of Harris Corporation, Communication Systems, 1680 University Avenue, Rochester, New York 14610-1887.

Copyright 2019
By Harris Corporation
All Rights Reserved

This Help is based on v2.2 of the Harris International IP Add-on.

HARRIS CORPORATION COMMUNICATION SYSTEMS
1680 University Avenue Rochester, New York 14610-1887 USA
Tel: 585-244-5830. Fax: 585-242-4755. http://www.harris.com