Introduction

The Harris Radio Situational Awareness (SA) Module Add-on, RF-7800N-BM310, is a position driver for hC2 PATROL and hC2 DISMOUNT. The information in this document is intended to help in configuring and deploying the driver using the hC2 Management tool.

The following functionality is provided as part of this add-on:

  • Situational Awareness (SA): The Harris driver is able to receive SA data from connected Harris radios and distribute them as Friendly Force Tracks across the hC2 Tactical Communication network.

  • Own Position: The Harris SA driver is able to report a specified SA track as its own position, to be used in hC2 Patrol or hC2 Dismount and distributed across the hC2 Tactical Communication network.

  • External Tracks: The Harris SA driver is able to report SA tracks for friendly forces, to be used in the Common Operational Picture and distributed across the hC2 Tactical Communication network.

Reference

Refer to the hC2 PATROL Administrator Manual or hC2 DISMOUNT Administrator Manual for use of the management tool. Refer to the hC2 PATROL Technical Data, 10515-0479-4020, or hC2 PATROL Release Notes, 10515-0479-4110, for hardware requirements.

Select this link to open an Acrobat Reader output of this document.

Position Driver Description

The Harris Radio SA Module integrates Harris radios delivered SA information (positions of radios in the same network) into hC2 Tactical Communication. From there, they are distributed over the tactical network to other hC2 installations and can be displayed in other hC2 installations. The information can also be used to update own position and time in hC2.

When the driver has been successfully configured, external radio positions reported by Harris radios are used as own position or external tracks, inserted and updated in hC2 Tactical Communication. This means that the radio positions are viewable in hC2 COMMAND, PATROL, and DISMOUNT as either own position or friendly force tracks.

The radio name/id will be used as “Call Sign” of the track.

It is possible to use this add-on in conjunction with the hC2 PATROL feature Track Aggregation Console which makes it possible to rename and define two radio position inputs as the same track.


Configuration

The position driver can be added and configured for a platform using the Sensors Dialog in the Management Tool.

Prerequisites

The radios must have the SA Packet Type set to “HARRIS” or "International" (other formats are not supported). See the Situational Awareness section of the individual radio manual for details on how to set the Packet Type.

Radios with PPP connection

The Platform must be configured with ‘Harris – UDP’ and the PPP connection between the PC with hC2 Tactical Communication and the Harris radio must be established and connected. This can be done using the Harris Network Radio Driver Installer (NRDI).

Notice that the configuration of baud rates in the NRDI driver must match the configuration in the radios.

Once the PPP link has been established (but not connected), you must also “dial up” the radio to establish the connection between the PC and the radio. If the connection is interrupted by preset page changes to the radio, entering the programming menu, hardware failures or other ways, then the connection is lost without a warning, and the user must “dial up” the radio again to re-establish the connection.

Firewall settings must not prevent the data packages from the radio to reach the hC2 Tactical Communication.

Harris 7800S radio

When using the Harris Position Driver with one or more Harris 7800S radios, the hC2 PATROL Vehicle Platform must be configured with ‘Harris – COM’ and the hC2 DISMOUNT platform with ‘Harris – USB’.


Compatibility

This add-on is generally compatible with Harris Falcon II and III radios providing SA functionality. Due to variations in the firmware versions on different radios, tests should be performed on the specific version of the radio to be used before general deployment.

This driver has been tested with the following radio models:

  • Harris RF-5800H-MP

  • Harris RF-7800H-MP

  • Harris AN/PRC-117F(V)(C)

  • Harris AN/PRC-152(C)

  • Harris AN/PRC-152A

  • Harris RF-7800V

  • Harris RF-7800M

  • Harris RF-7850M

  • Harris RF-7800S

  • Harris RF-5800M-HH

Other Harris radio models will likely also work with this driver for hC2 Tactical Communication as they use the same formatted messages. When using the Harris SA driver with hC2 DISMOUNT on a Harris tablet, be sure to have “Maintenance Mode” disabled from system settings. If the mode is disabled while the system is active, reboot the device after disabling to ensure a connection to connected radios.


About This Help

REFERENCE Number: 10515-0479-5011
JANUARY 2019
Rev D

Harris Radio SA Module Add-on

RF-7800N-BM310

This information/part is controlled by the U.S. Department of State International Traffic In Arms Regulations (ITAR), 22CFR 120-130, and cannot be exported from the United States or shared with a foreign person without prior approval from the United States Government.

Information and descriptions contained herein are the property of Harris Corporation. Such information and descriptions may not be copied or reproduced by any means, or disseminated or distributed without the express prior written permission of Harris Corporation, Communication Systems, 1680 University Avenue, Rochester, New York 14610-1887.

Copyright 2019
By Harris Corporation
All Rights Reserved

This Help is based on v2.2 of the Harris SA Module Add-on.

HARRIS CORPORATION COMMUNICATION SYSTEMS
1680 University Avenue Rochester, New York 14610-1887 USA
Tel: 585-244-5830. Fax: 585-242-4755. http://www.harris.com