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CPA Platform Help and Support 

Welcome 

The Communications Planning Application (CPA) is used for planning, configuration and 
programming of supported Harris radios. The platform help describes the overall user interface 
and features of CPA. 

For an overview of new features, refer to What's New. 

All acronyms used in the Help are defined in the Glossary. 

A Welcome screen provides new users with basic information and links to tutorials, and assists 
with feature location. Disable the Welcome screen by unchecking the Show Welcome 
Screen... box at the bottom of the Welcome screen. 

 

The Welcome screen can also be disabled as follows: 

1. Select Tools > Application Options menu. 

2. Select Platform in the left menu area. 

3. Select No in the Show Welcome Screen On Startup field. 
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Quick Start 

With CPA, a user can quickly create comprehensive communications plans. Featuring an 
intuitive user-interface, CPA permits a planner to create large-scale radio communications plans 
for distribution. 

Typical steps for creating a communications plan are listed below: 

NOTE - The steps below do not have to be done in the order 
listed. Not all steps are required depending on user requirements. 

1. Create a Topology. 

2. Create individual Networks. 

NOTE - Some CPA Products feature Wizards, which 
provide step-by-step instructions for network creation or 
other CPA activities. 

3. Open an individual Network by selecting its tab in the main CPA work area (see below). 
 

 

4. Add Stations and other devices to Network. 

5. Connect items within a Topology (optional step, used only if a topology is being used). 

6. Create (or Import) and Assign Keys. 

NOTE - Only non Type-1 keys can be created or imported. 
Type-1 keys must be loaded into the radio via separate fill 
device. 

7. Set the IP addresses of connected personal computers and/or laptops, if required. 

8. Validate the plan. 

9. Save the configuration by selecting File > Save or . 

10. Distribute the plan, if required. 

11. Program radios. 

NOTE - Each individual CPA product Help contains specific 
information on programming that radio type. 
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Help 

Interface Overview 

Window Layout and Options 

CPA permits numerous ways of viewing Window areas, which are described below. 

Window Layout 

The standard window layout of the CPA is to have the views docked with the graphical work 
area in the center view. 

In this arrangement, the Toolbox, Explorer, and Navigator become one tabbed view on the 
left. 

The Properties view is on the right, with Messages, Programming Status, and Plan Notes 
views tabbed along the bottom portion of the screen. 

Window Options 

The CPA application uses window panes to view different aspects of communication planning 
activities and resources. The windows panes can be positioned to best meet your working 
requirements. Layout capabilities include: 

Resizing - General ability to change the size of a window (standard window control). 

Floating - Places the window pane outside the application frame where it floats 
independently on the desktop and can be sized as required. 

Dockable - Allows the window pane to be inside the application frame or floating. Drag 
the frame from its docked position to move it about the display. Double-click the frame to 
return it to the docked position. If a pane is set to Floating, select Dockable from the 
context menu and then double-click the frame. To move the docking location, double-click 
the view heading and use the docking arrows to place the view in a new location. 

Tabbed Document - Places the window pane in the central viewing area as a tabbed 
document (same as Topology and Network views). See below example, where the 
Topology, Plan Notes, and a Fixed Frequency Net tab are shown. 
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Auto Hide - Minimizes a window pane or group of panes. For example, the minimized 
group shown below represents the Messages, Programming Status, and Plan Notes 
group. 

 

NOTE - Window > Auto Hide All minimizes all panes except 
tabbed panes. 

Hide - Closes the window pane. Use the View menu to open a closed pane. 

The View and Window menus are used along with the window pane control.  

Manage pane layouts: 

1. Select the triangle icon in the control's toolbar  to open the window pane 
control (see below). 

 

NOTE - The pin icon  is Auto Hide and the X icon is Hide. 
When the pin is down, Auto Hide is off, when it points left, Auto 
Hide is on. 

2. Select the layout option to change the window behavior as required. 

Context Menus 

Context menus are opened using the right mouse button on a typical button layout where the 
left mouse button does the primary selection activities. These menus are context sensitive to the 
item selected and provide a range of actions to perform on the plan element. 

For example, window panes can be made Floating, or Dockable; the toolbars shown or hidden, 
and tabbed documents closed. 
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Toolbars 

Toolbar buttons provide ready access to commonly used menu items. 

Select View > Toolbars or use the toolbar context menu to show (checked) or hide (not 
checked) available toolbars. 

 

The following standard toolbars are available: 

NOTE - Other toolbar items can display depending upon other 
installed CPA products. 

Standard Toolbar 

 

The Standard buttons are New, Open, Save, and Help Topics. 

Create Toolbar 

 

The Create toolbar buttons are Create Network, and Create Topology. 

View Toolbar 

 

The View buttons are Zoom In, Zoom Out, Zoom Reset, Zoom To Fit, Print Preview, Print 
View, and Save To JPEG. 

Tools Toolbar 

 

The Tools toolbar buttons are Manage Keys and Wizards. 
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Actions Toolbar 

 

The Actions toolbar buttons are Validate Plan and Program. 

Favorites Toolbar 

 

The Favorites toolbar contains a drop-down menu that allows you to show All Properties or 
Favorite Properties. In addition, three stars are available: 

• Show or hide favorites in the Properties panel 

• Add a currently selected property to favorites 

• Clear the existing list of favorites 

Customizing Buttons 

The buttons which display on the toolbars can be customized by selecting the downward 
pointing icon in several locations on the toolbar. This displays the Add or Remove Buttons 
menu. Then, navigate to the toolbar to be customized and check/uncheck buttons as desired 
(see example below). 

 

NOTE - The toolbars can also be reset to the default layout (with 
all selected) by pressing Reset Toolbar. 



Printed Documentation 

7 

Menus and Buttons 

Listed below is information on the menus and buttons available in CPA. 

File Menu 

The File menu contains those actions that are used to open and save communication plan and 
supporting files. Menu items and keyboard shortcuts (for example, Ctrl+N means to press and 
hold the Ctrl key and then the N key) are: 

New (Ctrl+N) - starts a new configuration plan. Unsaved changes to an open plan can be 
saved before starting a new plan. 

Open (Ctrl+O) - opens an existing CPA file (*. hcpa). 

Save (Ctrl+S) - saves the open plan to a CPA file (*. hcpa). 

Save As... - saves the open plan to a CPA file (*. hcpa) of a different name. 

Configure Password - sets/removes password to open the application. 

Import Plan Data - this menu item permits the importing of plan data for use by installed 
CPA products. Available formats may include: V-U RPA/ILOS RPA-compatible Format 
(*.vpd), Falcon III RPA-compatible Format (*.rnp), HF RPA-compatible Format (*.rpd), 
Harris RF-6705 Data File (*.csv), or an Exported Common Plan File (*.cpf). Available 
importable formats will vary depending upon what other CPA software products are 
installed. This menu will be inactive if no CPA products that support importing are 
installed. 

Export Plan Data - this menu item permits the exporting of plan data for use by other 
Harris software products. Available formats may include: V-U RPA/ILOS RPA-compatible 
Format (*.vpd), HF RPA-compatible Format (*.rpd), Falcon III RPA-compatible Format 
(*.rnp),  Harris RF-6705 Data File (*.csv), or Exported Common Plan File (*.cpf). Available 
exportable formats will vary depending upon what other CPA software products are 
installed. 

NOTE - The HF RPA-compatible Format (*.rpd) is not a Harris 
RPA plan file. It should only be used for importing communication 
plan data into the RF-6010 Network Management Application 
(NMA), Wireless Messaging Terminal (RF-6760W, RF-6760W-
HPW) applications. 

Page Setup - sets printer output paper size, source, orientation, and margins. 

Print Preview - shows currently active tabbed view in a print preview using the Source 
JPEG output option. 

Print (Ctrl+P) - prints currently active tabbed view using the Source JPEG output option. 

Save to JPEG - saves currently active tabbed view as a *.jpg file. 

Recent Files - select from the list of four most recently opened plans to open the plan. 
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Sample Plans - select from the list of sample plans to open the plan. 

Exit - closes the application. Unsaved changes to an open plan can be saved before 
exiting. 

View Menu 

The View menu supports the following activities. 

Plan Information - Opens the Properties window to the Plan Information configuration fields to 
Specify Plan Properties. 

Plan Report... (Ctrl+R) - Creates a Communication Plan Report. 

Select any of the following views to open the pane if it is in Hide (closed) or display the pane if it 
is in Auto Hide. 

Properties Window 

Toolbox 

Plan Explorer 

Plan Navigator 

Messages 

Programming Status 

Plan Notes 

Welcome Screen 

Toolbars - check to enable view of each item. 

Zoom Tools - Zoom can be used in either the Topology or Graphical Plan Report Views. 
Zoom In to see a smaller area, or Zoom Out to see a larger area. Zoom To Fit places all 
items on single page for easy viewing. Zoom Reset returns to the default scale. 

Create Menu 

The Create menu selections set up the basic network and topology structures into the 
tabbed document structure of the main graphical views. 

Create Network - Select this item to add a network (Fixed Frequency/LOS for example) 
from the list of available network types (availability depends on which CPA products are 
installed). 

Create Topology - Select this item to add a topology that contains networks and other 
stations. 

Create Map View - Select this item to Create Map View of a topology that contains 
networks and other stations. This feature is currently only available for CPA for RF-
7800W. 
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Actions Menu 

Two basic actions can be performed from the Actions menu: 

Validate Plan - This action performs a second-level validation on the communications 
plan. Information which may improve performance is provided to the planner for 
consideration before distributing the plan. For details, select this link. 

Program [Radio Name] - This action begins the process of filling the radio configuration. 
Radio connection is not always required. Certain radio types support fill file generation to 
a location on disk. Other radios need to be connected. For further information, select this 
link. 

Tools Menu 

These tools are available for selection from the Tools menu or by using the keyboard shortcuts 
shown. 

Application Options (Ctrl+T) - Refer to Application Options. 

View Plug-ins (Ctrl+L) - Refer to View Plug-ins. 

Key Management (Ctrl+K) - Refer to Working with Keys. 

Radio Monitoring  - [Optional Menu Item - installed by selected CPA products] Refer to 
Radio Monitoring. 

Reset - [Optional Menu Item - installed by selected CPA products] Select to display a 
menu of CPA table entries that can be reset. At the Reset Tool dialog, check the items to 
be reset as required. 

DSS Key Generator - [Optional Menu Item - installed by selected CPA products] In most 
cases, the mission plan file transfer will use the default DSS signature keys that are 
provided with CPA. However, the CPA also provides the option to generate custom DSS 
key pairs for mission file authentication. Refer to specific CPA product Help for 
instructions. 

Wizards - [Optional Menu Item - installed by selected CPA products] Select to display 
Wizards dialog. This feature provides menu-driven assistance for network creation and 
other CPA activities. 

HF Propagation Analysis - [Optional Menu Item - installed by selected CPA products] 
This feature provides useful information for communications managers to use when 
planning HF network details. 

Window Menu 

The Window Menu supports the following activities: 

Auto Hide All - Minimizes all CPA panels leaving tabbed views open. This option 
maximizes the main CPA work area. Refer to Window Layout and Options. 
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Close All Views - Closes all tabbed views in the main CPA work area. Alternately, use 
the context menu to Close a particular tab or to Close All But This tab. 

NOTE - Use the CPA Plan Explorer to re-open tabbed views in the 
main work area. Select each Topology and/or Network to re-open 
that item as a tab. 

Reset Window Layout - Returns all window panes to their default docked layout. 
Tabbed graphical layouts are not affected. 

NOTE - Also listed in the Window menu are each of the tabbed 
graphical views in the current plan. These may be selected to 
open that tab (see example below with Topology1 selected). 

 

Help Menu 

The Help menu contains information on application use, version information, and Harris contact 
information. 

Help Topics - Opens the Harris CPA Help which contains extensive information on all 
CPA products as well as specific instructions for performing many common functions 
within CPA. A search can be conducted which includes the CPA Platform and all installed 
CPA products. How Do I topics are also included here. 

Additional Help - Provides a link to additional Help content when installed by CPA 
Product. This material may include PDF Help addendums or reference materials. This 
menu will be disabled (grayed out) if no CPA products include Additional Help material. 

Supported Products - Opens dialog listing information on all installed CPA products. 
Each installed CPA product integrates one or more Harris radio types into the CPA 
application. 

About - The installed application's build information along with product identification. 
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Toolbox 

The Toolbox (View > Toolbox) contains Harris Radios, Networks, and Annotations that are 
placed into the network and topology workspace areas. A standard set of annotations is 
included with the CPA. 

Additional installed CPA products and Networks determine what items can be added to the 
communications plan. This can include devices such as the RF-6010, SIP Server, or the RF-
7800I. 

The toolbox is organized by: 

Harris Radios - Includes Harris VHF, UHF, HF, Multiband, and HCLOS radios supported 
by installed CPA products. Once a radio (station) is configured, the Plan Explorer or Plan 
Navigator can be used to add the same radio to another net. 

Devices - Includes Computers, RF-6010 stations, RF-7800I-CU stations, and SIP-
Servers supported by installed CPA products. 

Networks (Waveforms) - Includes networks for use with specific radios. Network types 
available based upon installed CPA products. 

NOTE - The Wizards icon   is shown to the right of 
Network/Waveform types which include wizard support providing 
step-by-step assistance with network or waveform creation. 

Annotations - Includes passive graphical elements used to record 
representation/comments within the Topology view. Annotations are grouped as follows: 

Building/Terrain - Building, Depot, Desert, Mountain, River or Tent/Shelter - just 
drag and drop to add. 

Comment  - Drag and drop to add comment text box, then type in required 
information. 

Device - Phone, Camera, Computer, Sensor, and many other commonly used 
devices - just drag and drop to add. 

Vehicle - Helicopter, Naval Vessel, Plane, Satellite or Ground Vehicle - just drag 
and drop to add. 

NOTE - Annotations are only used in Topology views. Select this 
link for instructions on using CPA-provided annotations. 

How to Define Different Station Default Configurations 

More than one Default of a station type at the same time is not supported. However, adding 
multiple stations with differing configuration can be done using the below process: 

1. Open the Toolbox and select the desired radio type. 
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2. Confirm that the Default <radio type> text is displayed at the top of the Properties menu 
(this indicates that the properties listed below will apply to the Default radio type, and all 
future radios of this type will have these same properties). 
 

 

3. Ensure required default settings in the properties displayed. 
 

 

4. Select the Toolbox to create all new required stations by dragging and dropping as 
required.  

5. Perform station creation until all required radios have been created with the first set of 
features. 

6. Access the Toolbox and select the radio type being configured.  

7. Confirm that the Default <radio type> is displayed at the top of the Properties menu. 

8. Select to make any required changes to the properties; this action changes the 
configuration settings for all future radio types created from the Toolbox. 

9. Access the Toolbox to create all new required stations by dragging and dropping as 
required.  

10. Perform station creation until all required radios have been created with the second set 
of features. 
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11. Perform the steps above as required until all radio assets have been added to your 
Communications Plan. 

How to Set Global Network Settings 

Follow the steps below: 

1. Open the Toolbox and select the network type. 

2. Confirm that the Global <network type> text is displayed at the top of the Properties 
menu (see example below); this indicates that the properties listed below will apply to 
the Default radio type, and all future networks of this type will have these same 
properties. 

 

3. Select to make required global settings in the properties displayed; the displayed 
properties can have global configuration settings established from the Toolbox (see 
example below). 

 

4. Access the Toolbox to create all required new networks by dragging and dropping as 
required. Continue until all required networks have been created with the required global 
features. 
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Plan Explorer 

The Plan Explorer (see below) provides a structured list of items used in the communications 
plan. 

 

This list is organized into the following: 

All Stations - Lists all defined Stations in the plan. 

All Networks - Lists all defined Networks in the plan. 

All Topologies - Lists all defined Topologies in the plan. 

All Maps - Optional menu item (CPA for RF-7800W only) that lists all defined Maps in the 
plan. 

Adding Defined Stations 

Once a Station is defined, it can easily be added to other Networks or to a Topology. Simply 
drag the radio from any portion of Plan Explorer where radio types appear (All Stations, All 
Networks, or All Topologies) into the desired Network or Topology. 

Adding Defined Networks 

Once a Network is defined, it can easily be added to a Topology. Simply drag the Network from 
the All Networks part of the Plan Explorer into the desired Topology. 
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Plan Navigator 

The Plan Navigator (see below) provides a user-selectable list of All Stations, Networks, or 
Topologies in use in the communications plan. This versatile menu permits a large number of 
operations to be performed as detailed below. 

 

The drop-down area may be used to filter displayed contents using the All Stations, All 
Networks, or All Topologies. Further filtering can be accomplished by selecting items within 
the All Stations, All Networks, or All Topologies lists. (For example, a listing displaying all of one 
particular radio type can be displayed.) 

Items can be deleted directly from the keyboard using the [Delete] key. Multiple items may be 
selected by holding down the keyboard [Ctrl] key. Items can also be added to Networks or 
Topologies by using drag and drop. 

Using the context menu, all items in the Plan Navigator may also be deleted, radios can be 
programmed, networks and topologies may be opened. 
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Properties 

The Properties menu displays configuration fields based on what plan element or plan 
elements (mission plan, radio, device, or annotation) is/are currently selected. 

When multiple plan elements are selected, only those fields shared in common can be 
configured. Validation checks are made and notification given if a property value is not valid. 

For Help on the properties of a particular plan element, refer to the specific Help for that CPA 
product. 

A typical Properties menu is shown below: 
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Property fields can use the following context menu selections: 

Undo (Ctrl+Z) 

Cut (Ctrl+X) 

Copy (Ctrl+C) 

Paste (Ctrl+V) 

Delete (Delete Key) 

Select All (Ctrl+A) 

Detail Dialogs (...) 

Typically, information is entered directly into the field, or a selection is made using the pull-down 
menu. 

When a field with an ellipsis button   is selected, it will open a more detailed dialog for 
extended editing. 

Expand All, Collapse All Buttons 

Properties can include additional levels of configurable items. These Levels can be opened 
individually (select +) or closed (select -). Select Expand All to open all + fields. Select 
Collapse All to close all - fields. 
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Add Properties as Favorites 

Individual properties can be added in the following ways. 

1. Select Add "<property>" Property to Favorites after right-clicking on a property you 
want to add. 

2. Select the  icon to add a property.  

Once favorite properties are added, you may view them in the following ways. 

1. Navigate to the toolbar and choose Favorite Properties from the drop-down.  

2. Select the stars located in the toolbar to view, add, or remove favorite properties as 
desired. 

 

Search Properties 

The properties of a selected station or network can be easily searched by using the Search 
Properties feature located at the top of the Properties menu (see below). 

 

Perform a search: 

1. Select what to search: 

• Select the desired station or network within CPA to search an individual station or 
network. 

• Select and hold [Ctrl] to make required selections (or use other methods of 
multiple selection) to search across multiple plan elements. 

• Select the desired plan element from the Toolbox to search Default (used for 
station) or Global (used for network) settings for a particular station or network 
type. 



Printed Documentation 

19 

• Select the desired plan element from the Toolbox to search across all instances 
of an Annotation type (Building/Terrain, Comment, Device, or Vehicle). 

2. Enter the desired search term within the Search Properties field. 

NOTE - Search term is limited to 25 characters and is not case 
sensitive. 

3. Select Search or press the keyboard [Enter] key (select Clear to erase text). 

4. Observe that all properties which match your search term will be displayed in the 
Properties menu area below. 

5. Observe that any property changes made will be applied to all selected plan elements. 
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Messages 

The Messages Pane displays informational error messages and their source such as: 

Initialization of services 

Version information 

Addition and deletion events 

Validation errors 

Delete a Single Message: 

1. Select the message to be deleted in the Message Pane. 

2. Select Delete Selection from the context menu, or press [Delete]. 

Delete All Messages: 

1. Select any message in the Message Pane. 

2. Select Delete All from the context menu. 
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Programming Status 

The Programming Status view becomes active when Actions > Program is selected or when 
the Program context menu is selected on one or a group of radios. The programming status 
messages report on the progress of the file transfer and the file source. Example status 
messages for fill file-based programming are listed below: 

Generating fill file for Radio1 

Signing file for Radio1 

Fill file created for Radio1 

Mission plan created 

Use the context menu to Delete Selection for a single message, or Delete All to clear all 
messages. 
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Plan Notes 

Use the Plan Notes view to document important information about your plan such as any 
changes and the date they were made. This information could be recorded in another 
application and then pasted into this view. The standard keyboard shortcuts for copy (Ctrl+C) 
and paste (Ctrl+V) can be used. 

NOTE - Only text will be saved. (Pasting formatted text will 
remove the formatting.) 

For example, if a range of spreadsheet cells gets pasted into the Plan Notes area and some 
cells have graphic elements, the graphic content will not display or be saved. 
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Graphical Layout Tools 

When viewing a CPA Topology, plan elements can be manually moved (dragged) around the 
screen to achieve the desired plan layout. 

Selected plan elements in a Topology can be moved around by using the keyboard arrow keys. 

Many PCs include a mouse with a mousewheel. Press the keyboard [Ctrl] key while using the 
mousewheel to zoom in/out to resize plan elements in topologies as desired. 

There are also several layout tools available from the context menu to help place plan elements. 
Context menu items that are available when one plan element is selected include: 

Remove - removes selected plan element from the main CPA work area. 

Delete - deletes the selected plan element from the plan. 

Bring To Front - brings selected plan element to the front of the main CPA work area. 

Send To Back - sends selected plan element to the back of the main CPA work area. 

Context menu items that are available when multiple plan elements are selected include: 

Align Left - lines up selected content so that left sides align. 

Space Even Vertically - applies even spacing to selected content up-and-down. 

Align Top - lines up selected content so that element tops align. 

Space Even Horizontally - applies even spacing to selected content side-to-side. 

Making Multiple Selections 

Select multiple plan elements: 

1. Select [Ctrl]. 

2. Select multiple plan elements by holding down the left mouse button and dragging a 
boxed area around the elements, or use the left mouse button to click on individual 
elements while holding down [Ctrl]. 

3. Select All Stations using the drop-down in the Network view.  

4. Select  to quickly remove all Stations from that Network. 

NOTE - This action does not delete the Stations from the entire 
Communications plan, just from that Network. This is by design so 
that radios may be reassigned to other Networks. 
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Tooltips 

A tooltip is a feature that provides information about a menu or toolbar item when the item is 
hovered over with the mouse. An example tooltip is shown below when the mouse is placed 
over the Save to JPEG Toolbar item. 

 

Tooltips can be helpful, especially for new users of an application. If desired, tooltips can be 
disabled within CPA by setting the related Application Options accordingly. 
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Language Considerations 

Normally, the application accepts only English language input characters from the user interface 
controls. Non-English entry is allowed into the following fields: File Dialog Input, Author, 
Organization, and Plan Description. Non-English entry requires the computer to be configured 
for the proper language option. Refer to the steps below. 

Set up Windows PC to use a different default display language as follows. 

1. Select Start > Settings > Control Panel using the Windows Start menu. 

2. Select Regional and Language Options. 

3. Select the Languages tab, then Details.  

4. Observe that the Text Services and Input Languages settings are displayed (see 
figure below). 

5.  Select the desired default input language using the drop-down on the Settings tab. 

6. Select OK. 

NOTE - Most typical languages are installed during a Windows 
Operating System installation. However, if the required language 
does not appear in the drop-down menu, then the Windows 
Operating System installation disks will be required to enable the 
desired language. 
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Planning 

Planning Overview 

The CPA allows a communication plan to be constructed without a connection to a radio. 
Specific planning steps depend on the scenario being implemented and user preferences. 

Standard configurations can be saved as Sample Plans. 

Your communication plan is implemented using: 

Network (refer to Create Network) 

Topology (refer to Create Topology) 

Map (refer to Create Map View) 

NOTE - The optional map view application is only available when 
the Map View plug-in is installed. Currently the Map View plug-in 
is only installed with the CPA for RF-7800W product. 

Installed Software Version Check 

When opening a plan, CPA compares the CPA version previously used to save the plan with the 
CPA version you currently have installed. This feature informs you whether you should upgrade 
your CPA installation for optimal performance. 
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Plan Information 

Select View > Plan Information to view/edit the properties of the plan. 

 

Plan Information includes the following fields: 

Name - This is the filename of the plan. 

Description - This field allows an extended description to be entered. A small display 
window is opened using the pull down. 

Author - This is the Name of the planner. 

Organization - This is the Name of group. 
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Using Sample Plans 

Harris-provided Sample Plans provide working examples of different types of networks. Sample 
Plans may be used as "starting points" for customers to use when designing their own 
communications plans. 

Sample plans are installed in the following location: 

C:\Program Files\Harris RF Communications\Sample Plans. 

CPA Product Sample Plans 

Refer to the CPA product Help for the sample plans provided with the package. Harris 
recommends that you make a copy of the sample plan file, rename it, and work using the copy. 
This will permit saving a revised plan without affecting or overwriting the original sample plan 
file. 

User Sample Plans 

Any user-created configuration can be saved as a sample plan by placing the *. hcpa file in the 
Sample Plans directory. 
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Constructing a Plan 

Working with Topologies 

Creating a Topology 

A Topology is a large-scale view available within CPA which can be used to allow graphical 
planning showing deployment and communication relationships including stations and networks. 

Select Create > Create Topology or select the Create Topology  button to create a topology. 

The system topology contains one or more member networks and stations and defines the 
relationships between these parts. Multiple topologies can be created. Each topology name 
must be unique. The default is Topology1, Topology2, and so forth. 

Two views of a Topology are available. Use the Topology Mode selection drop-down (see 
below) or the Property Editor Mode drop-down to switch between each view: 

 

NOTE - The default Topology view is Connectivity view. When 
using Connectivity view, each radio can only be a member of one 
network at a time. Refer to Using Open View. 

• Connectivity View - For network/scenario planning, use Connectivity Topology to define 
complex communication routing. CPA will automatically configure routing tables ensuring 
communication. Connectivity View shows a communication path among elements with a 
solid line. 

• Open View - For system planning, use an Open Topology to define optional 
communication paths. Open View shows network memberships with a dashed line. 

Graphical views will be saved and provided in plan reports, documenting both the property 
configuration within the plan as well as the diagrams illustrating the deployment. 

NOTE - The maximum number of topologies permitted within a 
single Communications Plan is 1000. 
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Using Connectivity View 

This view represents the connectivity path between radios. This view is restricted based upon 
radio preset (see example below). 
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In most cases, each radio can only be a member of one network at a time in this view. 
Exceptions to this include multi-hop networking, which can be illustrated in Connectivity mode in 
some CPA products, in the network types listed below. 
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Using Open View 

Open View represents potential network membership based upon radio preset setting. There 
are no restrictions in this type of view. In this view, a radio can be shown to be a member of 
several networks at once, with the radio's preset switch setting determining actual network 
membership at any given time. 
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Switching Topology Views 

1. Select any area of a Topology.  

2. Select next to the Mode property in the Property Grid and use the drop-down to choose 
the required view (either Connectivity or Open). 

 

NOTE - When attempting to switch between Open View to 
Connectivity View, you may be presented with one or more error 
messages if a radio is shown with membership in more than one 
network. Messages similar to the below may display: 
 
Connectivity topology does not allow simultaneous membership in 
different presets. 
 
One or more of the links in this topology are not supported in 
Connectivity mode. 

Right-click on all of the links except one, and select Disconnect (see example below). You will 
then be able to switch between Modes successfully. 
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Adding Networks 

Networks are added in any of the following ways: 

• Drag and drop onto a Topology from the Networks (Waveforms) section of the 
Toolbox view. This creates a network plan element in the Topology. Double-click this 
network plan element to enter the Network View (network tab gets added to views). 

• Select Create Network and then select the network to be added. This opens the 
Network View as a tabbed view. 

Add a Network to a topology: 

1. Open Plan Explorer. 

2. Select All Networks. 

3. Open Topology where network is to be placed. 

4. Select Network from the list of All Networks and drag and drop into the 
Topology. 

Networks (along with Stations and Annotations) can also be created directly from the Topology 
View toolbar (see below). 

 

Add a Network using the Toolbar: 

1. Select the desired network type using the left-hand drop-down. 

2. Select the New drop-down and choose single or multiple as required. 

3. Enter the number of new networks and choose OK If multiple was selected; the 
new networks will be added with new tabs for each. 

NOTE - Items on a Topology can be moved around by using the 
keyboard arrow keys. 
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Working with Items within Topology 

When connecting (linking) items within a topology, the radio or device being connected gets 
added to the network.  

Connect items within a Topology: 

1. Select the first item to be linked (network or radio). 

2. Select [Ctrl] and choose additional items to be linked (or use other methods for multiple 
selection). 

NOTE - Notice that the Connect tool   becomes active. 
If this does not happen, it is because the link being attempted is 
not allowed (refer to Messages window for detail). 

3. Select the active Connect tool . 

4. Select PPP or Ethernet as required if connecting radios. 

NOTE - PPP links appear with a green colored interconnecting 
line, while Ethernet connections display with a blue 
interconnecting line (see example below; radios 1 and 2 are 
connected via PPP, while radios 3 and 4 are connected via 
Ethernet). 
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Break the link by selecting the interconnecting line and choosing Disconnect after right-clicking. 

NOTE - Links can also be broken by selecting the two endpoint 

items and then selecting  or by 
selecting Delete on the keyboard. 

NOTE - If link paths intersect within a Topology, they will 
automatically "jump" at the point of crossing for more clear 
representation (see example below). 
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Property Pinning 

Property pinning is the ability for the user to “pin” a property from the property grid onto a 
Topology. 

Create a Topology, add a station/network. Select the station/network in the property grid. Either 
right-click on the property name, or select the pin icon that appears in the description area. A 
new annotation will appear on the topology that displays the property name and value. This 
value on the topology will refresh whenever the property updates (see example below - IP 
Address property previously added, and Subnet Mask property is being added via right-click 
option). 

 

Also, the user can modify the font style and color by right-clicking on the annotation on the 
topology, or using the property grid when the annotation is selected (see editing options below). 

 

The annotation will maintain relative positioning to the station/network it is related to whenever 
the station/network moves. When the annotation moves, the relative positioning will be adjusted. 
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Adding Annotations 

Annotations can be added to the topology configuration as a way to include comments and 
make representations about various aspects of the project. 

The Annotations window is located at the bottom of the left-hand side of CPA (see below). 

 

NOTE - Comment annotations display text fields. 

Add an annotation: 

1. Select and drag one of the above sets of annotations onto a network or topology. 

2. Select a specific type from the set and modify the Text field as desired. 

3. Select OK. 

The annotation text can also be changed in the Properties editor. While many characters can 
be entered if desired, best use of the graphical annotation is typically limited to a short name. 
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Removing a Topology 

Remove a topology: 

1. Select the Network to be removed In the Plan Explorer using the context menu. 

2. Select Delete from Plan (or use the keyboard Delete key) and if prompted, choose Yes. 

3. Select the Network to be removed in the Plan Navigator using the context menu. 

4. Select Delete from Plan and if prompted, choose Yes. 

NOTE - These actions do not delete or remove either the 
Networks or Stations that were in the Topology from the 
Communications Plan. This is by design, so that items can be 
reassigned as required. 
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Working with Networks 

Creating Networks 

A Network contains one or more member stations and defines the relationships between these 
stations and other network parts. Connectivity within the network ensures end to end 
communications. 

Wizard Network Creation 

Some CPA products contain wizards, which provide step-by-step instructions for network 
creation or other CPA activities. 

Wizards are accessible from the Tools Toolbar, if a CPA product is installed that contains a 
wizard. For information on wizards, refer to the specific CPA product Help containing the wizard. 

NOTE - Networks created using a Wizard display differently on the 
workspace tabs from Networks created manually, as shown 
below. 

 

Manual Network Creation 

Manually create a network: 

1. Select Create > Create Network and make network selection, or 

2. Select the Create Network button and make network selection, or 

3. Select and drag a selected network from the Toolbox onto a Topology. 

Multiple networks can be created. Each network name must be unique. The default depends on 
the type of network and follows a sequential naming pattern such as Network1, Network2, and 
so forth. 

NOTE - Some CPA products may prevent certain words from 
being used for a network name. 

Configurable Network Information includes: 

• Name 

• Description 

• Notes 

• Preset 
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Preset type cannot be changed for an existing network. Stations that are added must be 
compatible with the network type. 

An indication is provided whenever a network property or membership change causes other 
dependent properties to change. This indication includes all dependent properties modified as 
well as their new values (see below example). 
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Setting Network Properties 

Configure the properties of a network: 

1. Select the Network to be configured. 

2. Select the Property field in the Properties view to be edited. 

3. Set up the value as required.  

Some property values require selection from a list (such as True, False, High, Medium, Low, 
User). Others use keyboard entry (such as Description, Name, Notes). 

Help on the individual setting is displayed at the bottom of the Properties area. For additional 
information, refer to the Help for the specific CPA product. 
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Removing a Network 

Remove a Network: 

1. Select the Network to be removed with a Topology selected in the main CPA working 
area. 

2. Select the  button or right-click and choose Remove. 

3. Select the Network to be removed in the Plan Explorer. 

4. Select Delete from Plan and if prompted, choose Yes. 

5. Select the Network to be removed in the Plan Navigator.  

6. Select Delete from Plan and if prompted, choose Yes. 

NOTE - Each method of network removal can use multiple 
selection. 

NOTE - These actions do not delete or remove the Stations that 
were in the network from the communications plan. This is by 
design, so that items can be reassigned as required. 
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Working with Stations 

Adding Stations 

Add a new station to a network or a topology: 

1. Select a new station and drag it from the Toolbox. 

2. Select multiple new stations at the same time from Toolbox [right-click, select Create 
Multiple]. 

3. Select an existing station and drag it from the Plan Navigator. 

4. Select a station from the Network or Topology Toolbar [select radio type in drop-down, 
then select New or Existing as required]. 
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Setting Station Properties 

Set the properties of stations: 

1. Select the radio(s) to be worked with in the main CPA work area. 

2. Select the property field in the Properties view to be edited. 

3. Set up the value as required.  

Some property values require selection from a list (such as True, False or High, Medium, Low, 
User). Others use keyboard entry (such as Description, Name, Notes). 

NOTE - Some Properties use custom dialogs, which are identified 
by a  button to the right of the Property text. Select this button 
to make settings. 

Help on the individual setting is displayed at the bottom of the Properties area. For additional 
information, refer to the Help for the specific CPA product. 
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Removing Stations 

Remove a station from a network or a topology: 

1. Select the station or stations to be removed and press [Delete]. 

2. Select a station from the main CPA work area and press the Remove button , 
or right-click and choose Remove. 

NOTE - This action does not delete or remove the Station 
from the communications plan. This is by design, so that 
items can be reassigned as required. 

3. Select a station in the Plan Explorer, right-click, and choose Delete from Plan. 

NOTE - This action does remove the Station from the 
communications plan. (Notice the different prompt - Delete from 
Plan instead of just Remove.) 

NOTE - Other removal options are displayed depending upon 
context. 
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Working with Keys 

Encryption keys provide a method for increasing the security of information being transmitted 
and received over a communications network. The specific method of working with keys varies 
by both radio and network type. 

NOTE - Overviews are provided below regarding working with 
keys. Specific information is provided within each CPA product 
Help for that radio and its supported network types. 

CPA is capable of generating several different types of encryption keys. 

NOTE - The Key Generation feature is an optional component of 
CPA. This feature may not have been installed. 

The Manage Keys feature is accessed by selecting the   Toolbar icon, or by selecting 
Tools > Key Management from application menu. This feature allows the following actions: 

Import Keys/CAM 

Delete Imported CAM 

Enable Unrestricted Key Operation 

Change Key Generation Passphrase 

After keys are created or imported, key assignment in a network is done using the Properties 
menu area. CPA supports the following types of keys: 

• Unrestricted Keys - Either generated by CPA, or imported from *.csv file. Unrestricted 
keys can come from HF RPA Plan file (*.rpd), VULOS Plan file (*.vpd), CPA Plan File 
(*.hcpa), or a CPA Key Import file (*.csv). 

• Protected Keys - Imported comma-delimited files with the protected keys defined or 
read/imported from .hcpa files. Protected Keys can come from a CPA Plan file (*.hcpa), 
or a CPA Key Import file (*.csv). 

• Restricted Keys - Generated by Harris KGA and imported into CPA. Restricted Keys 
can come from an HF RPA Plan file (*.rpd), VULOS Plan file (*.vpd), CPA Plan file 
(*.hcpa), an imported Key Distribution file (*.kdf). 

The CPA can import restricted keys generated by the Key Generation Application (KGA) or it 
can use unrestricted keys generated by CPA. 

NOTE - There are three types of keys: Unrestricted, Restricted, 
and Protected. All keys in a plan must be the same type (for 
example, Unrestricted keys and restricted keys cannot be used 
together). 

  



CPA Platform Help and Support 

50 

Unrestricted Key Operation 

Unrestricted key operation can be password protected. The prefix for each key type can be set 
by the user if desired. 

1. Select the Manage Keys icon  in the CPA Toolbar area.  

2. Observe that the Key Manager dialog displays. 

3. Select Enable Key Generation (Unrestricted Key Operation). 

4. Select Yes or No at the No Key Generation Password prompt (this prompt can be 
disabled in Application Options). 

• If Yes is selected, Set Key Generation Password. Enter New Password, confirm 
and select OK. 

NOTE - If a password is assigned, the Set Recovery Password 
button can be used to establish a Question and Answer to enable 
password recovery. This feature should be set-up, if desired, at 
the same time as password assignment. 

• If No is selected, no password is set. 

NOTE - A password can be assigned later using the Change Key 
Passphrase button. 

5.  Select to delete restricted keys if they are in the plan and select OK to proceed. 

NOTE - A plan can only contain either all Restricted, all 
Unrestricted, or all Protected keys. Different key types cannot be 
mixed within a plan. 

NOTE - All Restricted or Protected Keys, along with the CAM 
Variable, will be deleted automatically whenever switching to 
Unrestricted Mode. 

6.  Select Generate.  

7. Observe that the Generate Keys dialog opens. 

NOTE - The Generate button will not be available unless at least 
one supported Key Type has been enabled in Application Options. 

8.  Select to make the required settings for each column: Type, # (number) of Keys, Prefix, 
Expires, Exp. (expiration) Date, Description as required. 

NOTE - The Prefix for each key type can be customized by the 
user if required by typing the desired prefix in the Prefix field. 
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NOTE - If required, an expiration date can be set for keys by 
checking the Expires box and manually entering the required 
expiration date. Selecting the down arrow in the Exp. Date field 
provides a calendar for use when setting the expiration date. 

9.  Select Generate Keys. 
10.  Observe that key values are generated for the selected keys and displayed in the list of 

keys.  

The Manage Keys dialog indicates the number of keys in the lower left corner and the fact that 
they are Unrestricted in the lower right corner (see example below). 

NOTE - Key values can be manually typed in, if necessary, by 
selecting the Value field and typing in the desired key. The user is 
restricted to the number of valid characters based upon the key 
type in use (32 or 64 characters). 

NOTE - Some types of keys require odd parity. If user modified 
keys have the incorrect parity, the user will be prompted (see info 
below). 

Parity 

Parity is calculated by counting the binary bits within each byte of data. For odd parity, this 
number of bits must be odd. DES keys require each byte within the key to have odd parity. If 
CPA is used to generate DES keys, the required parity is automatically assigned. 

For user-generated/edited keys, the parity can be determined by using the Microsoft Calculator 
in Scientific view to convert hexadecimal numbers to binary. 

To have a valid parity, each byte of the DES key must have odd parity (each pair of 
hexadecimal numbers in the key value make up a byte and there are 8 pairs total in a DES key). 

To figure out parity, convert each hex pair into binary (using the M/S Calculator in Scientific 
view) and count the number of 1s.  If the number of 1s is odd, the parity is odd.  If all bytes in 
the key value have odd parity, the key is valid. 

For example, 3E hex equals 0011 1110 in binary, has 5 ones and has the required odd parity.  If 
a user enters CC (1100 1100), that key has 4 ones, has even parity, and is therefore invalid. If a 
310MHH station uses that key, it will be flagged at Validation. 
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Unrestricted Key Ring Generation 

HF Networks use Key Rings for encryption. These are set up using the Key Manager and 
selecting Key Rings from the menu on the left-hand side of the Key Manager Dialog. See 
example below with five key rings previously generated. 

 

NOTE - In order for CPA for RF-7800H-MP to be able to perform 
Key Ring Generation, the application must have been installed 
with the Key Generation feature enabled. 

It is advised to set up Key Rings prior to setting up Networks and system presets so that keys 
are available to assign to the presets: 

1. Select the Manage Keys icon  in the CPA Toolbar. 

2. Ensure the Enable Key Generation (Unrestricted Key Operation) box is checked. 

3. Select Generate.  

4. Observe that the Generate Populated Key Rings dialog displays. 
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5.  Enter the Number of Key Rings, Key Ring Name Prefix, and Expiration Date as 
required (for the Expiration Date, either accept the None default, or select the drop-down 
to enter the required expiration date in the calendar that displays). 

6.  Select Generate.  
7.  Observe that the required number of Key Rings, along with the underlying keys, are 

generated. 

NOTE - Do not leave the computer unattended with the Key 
Manager dialog open. Although entry into this dialog can be 
protected by a password, once it is open a user is free to view, 
change or delete any of the keys. 

Although Keys (which are used by non-HF products) can also be configured in CPA for RF-
7800H-MP, they are for non-HF network types, and can be used in conjunction with Key Rings 
to synchronize crypto between HF and non-HF networks. 

Import Keys 

The keys generated by these applications can be imported into CPA: 

KGA Key Distribution Files (*.kdf) 

VHF-UHF/ILOS RPA Plan Files (*.vpd) 

HF RPA Plan Files (*.rpd) 

Comma-Delimited Key Files (*.csv) 

CPA Files (*.hcpa) 

NOTE - Keys can be imported over existing keys. If a key is 
assigned, it can be changed using the import if the key name and 
type are the same. In this case, the key will show in the import 
screen in a "muted yellow" color. If a key is not assigned, it can be 
changed using the import if the key name is the same. All values 



CPA Platform Help and Support 

54 

(type/value/expiration) will be updated from the key import line 
selected. 

Import keys: 

1. Select Import... to open the Import Keys dialog. 

2. Select Browse. 

3. Select the Key Based Algorithm. 

4. Enter the Key Encryption Key, if required (not all import types require this). 

5. Select OK. This opens the Import Keys dialog. 

6. Select the keys to be imported and choose Import. 

7. Select Close. 

The following password encryption algorithms are used by CPA: 

• Default KEK (128 bit) - Key Encryption Key entry is not required. 

• AES Passphrase (256 bit) 

NOTE - AES Passphrase is not supported on FIPS-complaint 
PCs. 

• AES (128 bit) - requires 32 characters. 

• AES (256 bit) - requires 64 characters. 

Restricted Key Operation 

Harris offers the Key Generation Application software product which can generate restricted 
keys. Restricted Keys cannot be generated, edited, or viewed within CPA. Restricted Keys must 
be imported into CPA after having been generated with the Key Generation Application. 

NOTE - Restricted Keys can also be present in HF RPA Plan file 
(*.rpd), VULOS Plan file (*.vpd), and CPA Plan File (*.hcpa) plan 
files. 

Restricted Keys offer increased security for radio communications. After Restricted Keys have 
been imported into CPA, they can be assigned to networks, but are not visible in the Manage 
Keys dialog. Note the absence of the Key Value cell. 



Printed Documentation 

55 

 

Protected Keys 

Protected keys can only be read from comma-delimited files with the protected keys defined. 
They can also be read/imported from .hcpa files that contained protected keys when saved. 

A template Excel file which can be used for Protected Key importing can be found at the 
following location: 

C:\Program Files\Harris RF Communications\Sample Plans\CPA Key Import Template.xls 

SMT Keyloader 

The SMT Keyloader feature (if installed only for RF-7800W CPA) is accessed by selecting 
Tools > SMT Keyloader. 

The RF-7800W Keyloader application allows the following actions: 

Add or Discover Device 

Certificate Authority (CA) Management 

Private Key/Certificate Generation (HTTPS, SSH, X.509 Authentication) 

Certificate Request 

Private Key/Certificate Loading (loaded by CPA) 

Wireless Pre-shared Key Management 
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Setting IP Addresses 

When a wireless IP network is established, the individual IP address of each PC and radio must 
be set to the proper values to permit communication. PC and Radio IP addresses must be 
determined for each station in the network. 

NOTE - Programming IP addresses into CPA software requires 
use of the IP Routing menu. Refer to CPA product Help for 
instructions. 

PC IP Addresses 

All PCs have a default IP address. In order to set up wireless communications, the default IP 
address of the PC will need to be changed to the PC IP Address that is required for the wireless 
IP net. This section provides instructions for identifying and modifying the IP address of a PC. 
These steps are for a PC running Windows 7. The process for modifying an IP address on other 
Windows operating systems is similar. 

Identify a PC IP address: 

1. Select Start > All Programs > Accessories > Command Prompt; alternatively, you 
may select Start > Run, type in cmd, and choose OK. 

2. Enter ipconfig at the command prompt and press Enter. 

3. Observe that the IP addressing information for the PC should display as shown below. 
This is sample data; your specific addresses will differ from those shown. 

 

Caution - Before proceeding, write down the details for your PC. 
This will enable you to return to the original settings after using 
CPA, if required. 
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Modify the IP address of a PC: 

1. Select Start > Control Panel > Network and Sharing Center to open the Network 
Connections dialog.   

2. Select Local Area Connection to open the Local Area Connection Status dialog. 

3. Select Properties.  

4. Observe that the Local Area Connection Properties dialog displays.  

The components listed on your system may vary. Contact your network administrator if you do 
not see the Internet Protocol menu item. Select Internet Protocol Version 4 (TCP/IPv4) 
or Internet Protocol Version 6 (TCP/IPv6) and select Properties to open the Local Area 
Connection Properties dialog, as shown below. 

 

5.  Select the Use the following IP address: button and type the PC IP address, Subnet 
mask, and Default gateway (if applicable) needed for the wireless IP network.  

6. Select OK.  

The above example uses the addresses for the base station. 
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Radio IP Addresses 

The designated radio IP address will be automatically loaded into the radio when CPA is used to 
program the radio. 
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Validating a Plan 

CPA performs an automatic check of programmed settings referred to as validation. This occurs 
automatically as the communications plan is being constructed and then can be performed as a 
final check when the plan is finished. 

NOTE - Plans are also automatically validated prior to 
programming. 

CPA performs a first-level validation automatically as a communications plan is being 
constructed. As a plan is being created, users are notified by pop-up windows when 
modifications are required. 

NOTE - Messages may also be output to the Messages window. 

The example below occurs when a new radio type is added to an existing Fixed Frequency 
Network. CPA will make all required changes automatically, but does provide the user an 
opportunity to make revisions if required. 

 

After a communications plan is fully completed, the planner should perform a second-level 
validation before distributing the plan. 

1. Ensure that all required additions and features have been incorporated in the plan. 

2. Select Validate Plan . CPA performs a second-level validation of the 
plan. 

NOTE - If your CPA installation includes CPA products released 
with CPA Platform v1.0, the Validate Plan feature will be disabled 
(grayed out). 

NOTE - Validation can be canceled if needed by selecting Cancel. 

3. Observe that when Validation is completed, a 'Validation Passed' indication will be 
added as a tab to the main CPA work area (this tab may be closed by right-clicking on 
the Plan Validation Results tab and selecting Close). 

  



CPA Platform Help and Support 

60 

4. Observe that a Validation Summary is also displayed on the Properties area of CPA (see 
example below). 

 

5. Observe that a breakdown of any Warnings, Advisories, or Messages is also shown. 
These indicate the following: 

• Warnings - Current configuration contains settings which should be corrected for 
a plan to be completely functional. 

• Advisories - Current configuration settings could impact performance. 

• Messages - Contains general information regarding settings only. 

NOTE - The communications plan can still be used if desired 
despite any Warning, Advisory, or Message. However, it is 
recommended that any issue noted during validation be 
considered and corrected if possible. 

Following Validation, the plan may be safely used and/or distributed. 
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Programming Radios 

Before beginning radio programming, if required, make sure your radio is connected as 
described in the radio documentation. 

NOTE - Plans are automatically validated prior to programming. 

Once connected to the CPA application, do the following: 

1. Select one or more Harris Radios. 

2. Perform one of the following to launch the Program dialog: 

• Select Action > Program [Radio Name]. 

• Select Radio context menu and select Program. 

• Select Program  from the Actions Toolbar. 

3. Observe the selected stations to be included in the output file in the Programming 
Dialog, and then set the Programming Parameters (File Name, Transfer Location, and/or 
IP Address) and Programming Options. 

4. Select Start Programming to start. 

5. Observe that if multiple stations are selected to be programmed, each radio type will be 
processed individually.  

6. Ensure the radio is properly connected as described in the associated CPA product.  

NOTE - If supported by the CPA product, radio 
programming file may also be transferred to a logical drive 
as described below. At least one transfer location must be 
specified. 

7. Monitor the Programming Status view for programming status messages and their 
source and refer to Programming Status for messages associated with programming. 

8. Observe that progress is shown during file transfer, and the ability to stop the transfer is 
included.  

9. Observe that a notification is provided if any additional steps are needed to complete 
programming of the radio at the end of fill file transfer. 

10. Observe that a success message is provided when there are no errors in the transfer.  

NOTE - Any parameters that are not programmed into the 
radio because of an unsupported feature are reported at 
the end of programming. Additionally, programming errors 
or warnings are also reported and the radio is taken out of 
programming mode. A programming log file is available for 
review. 
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11. Select a location, such as the Desktop, to write the file if it is able to be transferred to a 
logical drive and complete the radio programming by transferring the file to the radio as 
described in the radio documentation. 

NOTE - Some Harris radios are programmed via a direct cable 
connection from the PC to the radio. Refer to the radio 
documentation for details. 
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Support Tasks 

Configure Password 

The ability to password protect the application is provided. When a password is used, it must be 
entered to open the application. 

1. Select File > Configure Password.... 

2. Enter a New Password. 

3. Confirm New Password. 

4. Select OK. 

Password considerations are: 

• The password can be a minimum of six and a maximum of 15 alphanumeric characters. 

• Only users running under Windows Non-Restricted User mode can access and modify 
the application password. 

• Three attempts at logon are allowed. Otherwise, application will need to be installed 
again. 

Remove Password 

Remove password protection: 

1. Select File > Configure Password.... 

2. Enter Existing Password. 

3. Select Remove password protection. 

4. Select OK. 
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Export Plan Data 

CPA can export plan data in several file formats which are detailed below. 

NOTE - Interchange File (*.int) export may not be available 
depending upon the installed CPA products. 

Select File > Export Plan Data to save the plan data into the following formats: 

Harris-compatible Import format (*.vpd) - Used for VHF-UHF/ILOS RPA Plan Files. 

NOTE - This does not export the actual plan in a form that can be 
opened in the VU/ILOS RPA, but instead contains pertinent 
information to support import into other Harris applications only. 

Harris RF-6705 Data File (*.csv) - this file format can be imported into TacChat IP. 

Exported Common Plan Files (*.cpf) - An XML-type file format which can be imported 
into RF-6760W / RF-6760W-HPW Wireless Messaging Terminal software and the RF-
6010 Network Management Application. 

Interchange File (*.int) - Used for the exporting of configuration data between Harris RF-
5800M-MP units and Rockwell Collins RT-8100 radios (refer to Rockwell Collins 
documentation for instructions). 
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Save to JPEG 

The current tabbed view or set of plan elements in the tabbed view can be saved to a JPEG file 
that can be opened in Microsoft Paint for example. Select File > Save To JPEG.... The output 
options (Choose Image Size) are: 

Screen - fits the images on the tabbed view into a fixed width and height 1280 by 996 
pixel image area. 

Source - keeps the images at 100% scale and only saves area where images are 
located. The width and height are fixed by the layout. 

Custom -  fits the images into an area entered into the Width and Height (default is 
current actual image area). Only integer values can be entered. The key to using this is to 
keep the image proportional to the current actual image area. So, if the source image is 
600 by 300, a proportional scale is 60 by 30 (smaller image) or 6000 by 3000 (larger 
image). 

After making your selection, select OK and save the file. Note that 13 pixels are added to the 
height at the top for the title (the name of the tabbed view). Also, images that are out of the 
current zoom area of the tabbed view will have a gray border around the plan element. If the 
orientation of the image area (select Source and look at the values in the custom width and 
height boxes to see actual size) is the opposite of the default 1280 by 996, then the image will 
rotate to achieve a best fit. 
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Create Reports 

Select View > Plan Report to produce a summary report of the currently opened plan file. This 
report has the following sections (see example below): 

Plan Information 

Station Summary 

Station Details 

Network Summary 

Network Details 

Topology Summary 

Topology Details 

Global 
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The output can be saved to the default location (C:\Documents and Settings\User\My 
Documents\Harris RF Communications\CPA) or any other location as: 

Portable Document Format (PDF) 

Microsoft Excel format (*.XLS) 

Microsoft Word format (*.docx)  available starting in Platform v1.6 

Communication Plan Report Toolbar 

 

Use this toolbar to do the following: 

 

Show or Hide Document Map (left pane) 

 

go to pages in the report 

 

refresh the report 

 

print the report 

 

view print layout 

 

configure page setup 

 

export to file 

 

view page options (Whole Page, 500%, 100%, etc.) 

 

find text in report 
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Application Options 

Use Tools > Applications Options... to set default names, values, and behavior of the installed 
radios and features. Restore Factory Defaults applies to the currently selected set of options. 
Restore All Factory Defaults applies to all installed options. After setting options, select OK to 
accept or Cancel to discard the changes. 

NOTE - Radio and Waveform options are described in their 
associated CPA product Help. 

Platform / General User Options are: 

Default Topology Name Prefix (type in as required or accept default) 

Default Topology Mode (select Connectivity or Open) 

Prompt Before Removing Station (Yes or No as desired) 

Prompt Before Removing Network (Yes or No as desired) 

Prompt Before Removing Annotations (Yes or No as desired) 

Prompt Before Removing Topology (Yes or No as desired) 

Show Welcome Screen On Startup (Yes or No as desired) 

Show Tooltips in Menus and Toolbars (Yes or No as desired) 

Show Tooltips for Plan Elements (Yes or No as desired) 

Save Properties Panel Width (Yes or No as desired) 

Key Manager options are: 

Prompt to Set Password for Key Generation (Yes or No as desired) 

Supported Key Types (Enabled or Disabled as required / Type in desired prefix or accept 
default) - example screen below. 
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NOTE - If a key type is disabled using the setting shown above, 
but then a Communications Plan is opened which uses one of the 
disabled Key Types, CPA will automatically enable that Key Type 
while the plan is in use. In this instance, a message similar to the 
following will display. 

 

NOTE - The change discussed in the dialog above is only made 
while the opened plan is in use. When this plan is closed, the 
Supported Key Types are returned to prior values. 

NOTE - A similar situation occurs when new key types are 
imported, except that the new imported key types stay enabled to 
permit use. 

  



CPA Platform Help and Support 

70 

Enable Key Rings - (Yes or No as desired) 

NOTE - Key Rings are used only by the RF-7800H-MP. 

Default Key Ring Prefix - leave at default of TEK, or select within field and overtype to 
revise. 

Property Pin options are: 

Show Warnings - (Yes or No as desired) 
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View Plug-ins 

Select Tools > View Plug-ins to open the Plug-in Viewer. The plug-in viewer includes detailed 
information for installed plug-ins. Select the Save... button to save all plugin information to a file 
or the Copy to Clipboard button to paste the information into another destination. See below 
for an example Plug-in Viewer display. 
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Configuration Extractor 

Installed along with the CPA Platform is the CPA Configuration Extractor tool. This is accessible 
from the Start Menu in the Communications Planning Application folder (see below). 

 

This tool can be used to provide useful information on any CPA Plan. It provides detailed 
information on the CPA Software products used to create and edit the plan being analyzed. This 
information can be helpful if compatibility issues are ever encountered. 

Below is an example of this tool viewing the contents of a previously created CPA Plan.  

Use the CPA Configuration Extractor: 

1. Open the tool from the Start Menu. 

2. Select Open from the CPA Configuration Extractor's menu bar and navigate to the 
location of any *.hcpa file. 

NOTE - Information can also be imported into the CPA 
Configuration Extractor using the menu bar's Import button. 

3. Select the desired *.hcpa file and select Open (see below). 

NOTE -  The second sample is from CPA for RF-7800W plan 
installed (Windows 7 style screen). 
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4. Observe the information on the left-hand side of the dialog and copy information about 
individual fields as required by selecting Copy or by using Copy All to capture everything 
from the visible menu.  

NOTE - This information can then be pasted into a text editor such as Microsoft 
Notepad. 

5. Select Export from the menu bar to copy all the detail from the entire plan in *.xml 
format; an excerpt from a sample export file (opened with Notepad) is shown below: 
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Create Map View 

Create Map View (Option for only CPA for RF-7800W) 

CPA Platform supports an optional mapping view application that is only available when the 
Map View plug-in is installed. Currently the Map View plug-in is only installed with the CPA for 
RF-7800W product. The map view contains a world map (default map view) and support for 
GeoTiff, Digital Topographic Elevation Data (DTED), Shuttle Radar Topography Mission 
(SRTM), and ShapeFile map file types. 

The mapping view application is launched from the task bar by selecting Create Map View > 
Create Layered Map. The GPS coordinate system for mapping supports Decimal Degrees (dd), 
Degrees Decimal Minutes (dd mm), Degrees Decimal Minutes Seconds (dd mm ss) or Military 
Grid Reference System (MGRS). The default setting is Decimal Degrees. 

The user can configure the unit of length to be Imperial (miles, feet, etc.) or Metric (kilometers, 
meters, etc.). Stations and network elements can be dragged/dropped/moved on the map for 
use in the plan or removed from the map. 

The map view displays the GPS coordinates and altitude information (if elevation data is 
loaded). Select, pan, and zoom functions are available on the toolbar. 

The following line characteristics are represented on the map for differentiation of network 
elements and link connections: 

• Black Lines - drawn between all networks and member stations 

• Green Lines - drawn between all items connected by a PPP link 

• Blue Lines - drawn between all items connected by an Ethernet link 

• Red Lines - drawn between all items connected by a RS-232 link 

• Orange Lines - drawn between all items connected by a SNMP link 

Supported map type file extensions consist of: 

• Geo Tiff (*.tif) 

• DTED (*.dt0, *dt1, *.dt2) 

• SRTM (*.hgt) 

• ShapeFile (*.shp) 

NOTE - Users can also import their own maps for use in a plan. Refer to CPA for RF-7800W 
for details on using the mapping view application. 
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Radio Monitoring 

Radio Monitoring (CPA for RF-7800W only) 

CPA Platform supports a Radio Monitoring property that provides status monitoring of all 
connected RF-7800W radios. Monitoring can be done on a single radio using the property grid 
or on multiple radios by pinning the desired properties onto a topology. 

NOTE - Radio Monitoring is accomplished using SNMP. In RF-7800W CPA, make sure to 
enable SNMP by choosing either v2c or v3 for the SNMP mode on the radio(s) you monitor. 

 

From the task bar, select Tools > Radio Monitoring. The Monitoring Configuration dialog is 
displayed. You can also right-click on a station (in Topology or Map view) that you wish to 
monitor and select Monitoring > Configure Monitoring. Select Monitoring > Start 
Monitoring for radio(s) that have been previously configured. 

 

OR 

 

NOTE - Refer to CPA for RF-7800W for details on the Radio Monitoring property. 
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Technical Support 

Support Overview 

We recognize that continued success in our business requires an on-going commitment to 
customer support. We offer this support not only through our sales and service facilities in 
nearly 120 countries around the world but also through our Field Engineering Department. This 
department can assist our customers in the specification, installation, operation, and 
maintenance of all of our products. 

In addition, further help is available via direct communications with our main facility in 
Rochester, New York using any method shown below: 

Mail 

Harris Corporation 
Communication Systems 
1680 University Avenue 
Rochester, NY 14610 
USA 

Telephone 

1-866-264-8040 (toll-free) 
1-585-242-3561  

Fax 

1-585-242-4483 

E-mail 

TAC@harris.com 
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What's New 

The CPA Platform v1.8 includes the following updates and features: 

• Support for Property Favorites feature, which allows users to designate individual properties 
as favorites 

• Support for Property Panel Width feature 

• Support for Version Check feature 

• Usability improvements to Help 
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Supported Operating Systems 

The supported operating systems for CPA Platform are: 

• Windows 8 (32 and 64-bit) 

• Windows 8.1 (32 and 64-bit) 

• Windows 7 (32 and 64-bit) 

• Windows Vista (32 and 64-bit) 

• Windows Server 2012 (32 and 64-bit) 

• Windows Server 2012 R2 (64-bit) 

• Windows Server 2008 R2 (32 and 64-bit) 

• Windows Server 2008 (32 and 64-bit) 

• Windows Server 2003 (32 and 64-bit) 

• Windows XP Pro (32-bit) 

Other OS Info 

• CPA Platform is compatible with foreign language Operating Systems when non-English 
localization is enabled. 

• CPA Platform is compatible with FIPS-compliance enabled OS. 

NOTE - Information on Supported Radio Products, including part 
numbers and firmware information, are obtained by selecting Help 
> Supported Products. 

  



Printed Documentation 

81 

Compatibility 

This listing shows software that inter-operates with CPA Platform v1.7: 

Import Keys 

• KGA Key Distribution Files (*.kdf) 

• VHF-UHF/ILOS RPA Plan Files (*.vpd) 

• HF RPA Plan Files (*.rpd) 

• Comma-delimited Key Files (*.csv) 

• CPA Files (*.hcpa) 

Export Plan Data 

• RF-6760W / RF-6760W-HPW Wireless Messaging Terminal software 

• RF-6010 Network Management Application 

Other File Formats 

• Export graphical views as images (*.JPG) 

• Export plan reports to spreadsheet (*.XLS) 

• Export plan reports to Adobe Reader (*.PDF) 

• Export plan reports to Microsoft Word (*.docx) 
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Troubleshooting 

This section provides information on troubleshooting questions. Questions are grouped by 
activity types (Installation, Configuration, Operation, and Programming). 

Installation 

Why does my installation take so long? The CPA software may require Microsoft 
support software.  The CPA installs this 
software when not yet installed. This may take 
significant time and/or require reboot prior to 
installing the CPA software itself. 

For example, the .NET 3.5 installation also 
includes service packs for previous versions of 
the framework. The amount of time that the 
installation will take depends on what versions 
of the .NET Framework and what service 
packs are already present on the target 
machine. 

Is there any third-party software known to be 
incompatible with CPA? 

No known support issues exist. 

While attempting to install the CPA, the “Files 
in Use” dialog opens up. What should I do? 

Close all applications listed in the Files in Use 
dialog, and then continue the CPA installation 
process. 

If the “CD Browser” is listed in the Files in Use 
dialog, you must copy all files from the 
installation CD to a folder on your hard drive, 
and run the PPS_IntroProgram.exe from your 
hard drive instead of installing the CPA directly 
from the installation CD. 

When I open a large CPA plan file by double-
clicking on the icon of the plan file, the CPA 
application does not appear for a long time. 
Can anything be done to speed this up? 

When opening a file by double-clicking on the 
data file, the entire file is first read by the 
application before the User Interface is shown. 
Loading a large (2 MB or over) plan file takes a 
few minutes depending on how much and how 
complex the data in the plan is. 

Instead, launch the CPA application first and 
then open the file using the File > Open 
command. 
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How do I set up my Windows PC to use a 
different default display language (for non-
English localization)? 

Refer to the Language Considerations topic. 

Configuration 

Where is the plan validity feature which allows 
me to set dates for the plan to be considered 
valid? 

This feature from the Radio Programming 
Application (RPA) products is not provided by 
the CPA. Consider using the Plan Notes area 
to store this type of information. 

Can I use the Toolbox to define different 
Station Default configurations? 

Refer to How to define different Station Default 
configurations. 

When opening a plan file I received a message 
that I am missing software. What does this 
mean and what do I do? 

The original plan was created by an installation 
of CPA with additional CPA products installed. 

When this happens, the plan will open partially, 
and provide access to radios and support 
matching only your installed products. 
Networks that contained any radio types not 
supported in your version of CPA will be 
removed. 

If you require the full plan to be opened, you 
need to install the missing CPA product 
software. Following the required software 
update, the original CPA plan will open with all 
its original contents. 

Why can't I open an exported plan (*.vpd) file 
using either CPA, VHF-UHF RPA or ILOS 
RPA? When I double-click a plan exported by 
CPA, it opens the RPA product but the plan 
itself fails to open. 

The *.vpd format used by the CPA to export is 
not identical to the plan format used by the 
VHF-UHF RPA and ILOS RPA products. This 
format cannot be directly opened by any Harris 
application, including CPA, and is only 
designed to provide station information for 
other Harris applications. 

The side-effect of using the *.vpd file extension 
for interoperability as part of the "Harris-
compatible import format (*.vpd)" option 
provided by CPA is that the RPA product will 
launch and then try to open the file but will fail. 

I need to create numerous radio stations with Refer to How to define different Station Default 
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similar configuration settings. Does CPA 
provide the capability to create a default radio 
with settings that can be re-used? 

configurations. 

I need to create numerous networks with 
similar configuration settings. Does CPA 
provide the capability to make global network 
settings that can be used to create networks 
that have the same global settings? 

Refer to How to Set Global Network Settings. 

When attempting to open, save, or import a 
CPA plan, I am receiving an error dialog 
reading either FIPS Compliant PC or FIPS 
Error. What is the problem and what can be 
done about it? 

Certain encryption types and waveforms will 
experience errors when open, save, or import 
operations are attempted on a FIPS compliant 
personal computer. These include the use of 
AES Passphrase (256 bit) and TALON-based 
Products. 

NOTE - AES (128) and AES (256) encryption 
types can be used without experiencing these 
types of error dialogs. 

If an error dialog is displayed, the text within 
the error dialog should be carefully read, and 
the changes suggested within this error dialog 
should be implemented. 

Background - Federal Information Processing 
Standard (FIPS) Publication 140-2 is a 
computer security standard issued by the 
National Institute of Standards and Technology 
(NIST) to accredit cryptographic modules for 
government computing platforms. FIPS 
standards provide an increased level of 
network security. Contact your organization's 
IT department for information on FIPS 
compliance requirements. 

Why can’t I connect the same station to two or 
more networks in the Topology view? 

Refer to Using Open View and Switching 
Topology Views. 

I dragged two existing stations, already 
connected via a station-to-station link, to a new 
Topology. However, on the new Topology I 
don’t see the link between the two stations. Is 
this a problem? 

No, it’s not a problem. The stations are still 
linked in the plan, but the connecting link will 
not be redrawn in a different Topology. 

If the Encryption Keys password gets lost, what There is no way to recover a lost password. If a 
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can be done to recover it? password becomes lost, you must do a full 
application uninstall and then reinstall the 
application. You may then create new 
passwords for encryption keys. 

Operation 

Why is the Property Editor not showing all the 
text in the property fields? 

The Property Editor does not wrap text, and 
some property names require more space than 
is provided by default. Adjust the default size 
and location as desired. Settings are saved 
across sessions. 

Why is File > Configure Password... not 
accessible? 

 

To configure the CPA password, a user must 
log-in with Administrator access. 

Applications may be launched by default with 
Non-Administrative privileges even if the user 
is logged in as an administrator. 

To run the CPA application as an 
administrator, right-click on the CPA desktop 
shortcut and select Run as administrator (see 
figure at left). 

Why is File > Save To JPEG... showing some 
elements with gray border or rotating image? 

A gray border appears around elements that 
are in the view being captured but are not fully 
visible on the screen. 

Images may be rotated by the Save to JPEG 
feature when necessary to achieve a best fit. 

Why do "How Do I" links not playback? In order to play "How Do I" multimedia clips, 
you must install Adobe Flash Player. This 
software is provided on your CPA product CD 
and is accessible from the autorun application. 

I cannot see some of my application panels. Is 
there a way to reset CPA window positions and 
sizes after items have been moved, docked, or 
resized? 

CPA includes the capability to customize your 
work environment in many ways, including 
changing the default window layout, resizing, 
docking and hiding of user interface 
panels/toolbars. 

Installing additional CPA products may also 
affect the visibility and positioning of some 
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CPA elements. 

If it becomes necessary to revert all application 
window layout to factory defaults, this can be 
done from the CPA menu by selecting Window 
> Reset Window Layout (see figure at left). 

Why am I seeing unusual characters when I 
type data into fields using a Windows Foreign 
Language package (non-English)? 

This software uses standard English language 
characters in most input fields because these 
characters are programmed directly into the 
radio. 

Some CPA fields allow foreign language 
characters. Fields that accept non-English 
entry are: 

File Name in File > Save and File > Open 
dialogs 

Author 

Organization 

Plan Description 

Annotation Text 

I don't have a mouse for my computer, just a 
keyboard. Can I still use the CPA? 

The Microsoft Accessibility MouseKey options 
can be set up to use the keyboard to emulate a 
mouse. Select Start > Settings > Control 
Panel > Accessibility Options and then 
select the Mouse tab to access MouseKey 
options. Refer to the Microsoft Windows Help 
application for additional details. 

NOTE - CPA also partially supports keyboard 
navigation. 

Can I change my Microsoft Windows 
appearance while CPA is running? 

Yes. 
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What is the difference between CPA's 
Connectivity View and Open View, and how do 
I switch between the two views? 

Refer to Using Connectivity View,  Using Open 
View, and Switching Topology Views. 

Are multiple instances of the CPA application 
allowed to run simultaneously? 

Yes. 

Programming 

Does the CPA support reading the mission 
plan from the radio? 

The CPA does not support this feature at this 
time. 

After programming the radio with imported 
keys, the order appears differently. Is this a 
problem? 

No, this is not a problem. The CPA sorts the 
key display by key name alphabetically. 

For example, if there are 5 keys numbered 1, 
2, 8, 10, and 15, they will be displayed in this 
order: 1, 10, 15, 2, 8. This ordering is only in 
the display; the radio is always programmed 
correctly. 

I programmed my radio from a CPA plan but 
not all the features are active. What 
happened? 

The radio that was programmed may have 
different system firmware installed that does 
not accept all features available in CPA. 

If the user programs a different radio firmware 
configuration, some settings may not program 
or may program differently. It is recommended 
to update the radio's firmware on a regular 
basis. Contact Harris for firmware update files 
and more information. 

Additional Information: A radio may be 
available with either a Standard (SW001) or 
Advanced (SW002) feature set. 
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Glossary 

-A- / -B- / -C- 

AES Advanced Encryption Standard 

ANW2 Adaptive Networking Wideband Waveform 

BGAN Broadband Global Area Network 

CAM Customer Algorithm Modification 

CD Compact Disk 

CPA Communications Planning Application 

*.cpf Exported Common Plan File, a format used in CPA export 

*.csv Comma separated variable, file format used in Microsoft 
Excel (also used for Harris RF-6705 Data File compatibility) 

Ctrl Control (key on keyboard) 

-D- / -E- / -F- / -G- / -H- 

DES Data Encryption Standard 

*.docx Exported plan file format (MS Word) 

DSS Digital Signature Standard 
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*.dt0, *dt1, *.dt2 Map type file format  (DTED) 

DTED Digital Topographic Elevation Data 

Exp Expiration 

FIPS Federal Information Processing Standard 

GPS Global Positioning System 

HCLOS High Capacity Line Of Sight 

*.hcpa File format used for CPA plans 

hex Hexadecimal (a base-16 numbering format using 0-9, and A-
F) 

HF High Frequency 

*.hgt Map type file format (SRTM) 

http Hyper text transfer protocol 

HPW High Performance Waveform 

-I- 

ILOS International Line Of Sight (RPA) 
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*.int Interchange file format (used in Rockwell Collins radios) 

IP Internet Protocol 

IT Information Technology 

ITAR International Traffic In Arms Regulations 

-J- 

JPEG Joint Photographic Experts Group (an image format) 

-K- 

*.kdf Key Distribution Files 

KEK Key Encryption Key 

KGA Key Generation Application 

-L- 

LOS Line of Sight 

-M- / -N- 

MGRS Military Grid Reference System 

MP Manpack 
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NIST National Institute of Standards and Technology 

NMA Network Management Application 

NRDI Network Radio Driver Installer 

NY New York 

-O- / -P- / -Q- 

OS Operating System 

Parity Parity is calculated by counting the binary bits within each 
byte of data. 

PC Personal Computer 

PDF Portable Document Format 

Plan Element Name given to any CPA component (mission plan, radio, 
device, or annotation). 

PNRDI Pocket Network Radio Driver Installer 

PPP Point-to-Point Protocol 

-R- 

RF Radio Frequency 
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*.rnp Falcon III RPA-compatible Format 

RPA Radio Programming Application 

*.rpd HF RPA plan file format 

RSSI Received Signal Strength Indication 

-S- / -T- 

*.shp Map type file format (Shape) 

SINADR Signal-to-Noise and Distortion Ratio 

SIP Session Initiation Protocol 

SNMP Simple Network Management Protocol 

SRTM Shuttle Radar Topography Mission 

TCP/IP Transmission Control Protocol/Internet Protocol 

TEK Transmission Encryption Key 

*.tif Map type file format (GeoTiff) 

-U- 

UHF Ultra High Frequency 
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USA United States of America 

-V- / -W- 

*.vpd V-U RPA/ILOS RPA-compatible Format 

VHF Very High Frequency 

VULOS VHF UHF Line of Sight 

WMT Wireless Messaging Terminal 

-X- /-Y- / -Z- 

*.xls Microsoft Excel file format 

*.xml Extensible Markup Language file format 

  



94 

Index 

* 

*.vpd file format 82 

6 

6705 Data File 7 

A 

Accessibility Options 82 
Acronyms 88 
Actions Menu 7 
Add or Remove Buttons 3 
Administrator 82 
Adobe Flash Player 82 
Advisories 59 
AES (256) Passphrase 82 
Align Objects 23 
Analyze CPA plan 72 
Annotation 40 
Application Options 68 
Auto Hide 7 

C 

Changing Windows appearance 82 
Command Prompt 56 
Communication Planning 27 
Communications Plan 41, 45 
Configure Password 82 
Connectivity View 30 
Context Menus 7 
CPA Configuration Extractor 72 
CPA operational summary 2 
Create Menu 7 
Create Topology 30 
Creating a default radio 82 

D 

Default KEK 49 
Default radio 82 
Default Station Properties 82 
Delete 41, 45 
Description 44 
Devices 71 
Disable tooltips 24 
Disconnect 82 
Display Language 82 

Distribution Files 81 

E 

Encryption Keys 49 
Error opening plan 82 
Errors 59 
export in *.xml format 72 
Export Plan 64 
Export Plan Data 81 

F 

FAQ 82 
Federal Information Processing Standard 82 
Field 16 
Fields which allow non-English characters 

82 
Files in Use 82 
Filtering 15 
FIPS Compliant PC 82 
FIPS Error 82 
Frequently Asked Questions 82 

G 

Global network settings 82 
Glossary 88 
Gray border on image 82 

H 

Harris Contact Information 7, 78 
Harris CPA Help 7 
Help Menu 7 
Help Reference Number 1 
Hover mouse 24 
How Do I 7 
How Do I clips 82 

I 

Import Keys 81 
Incompatible software 82 
Index 7 
Installing 82 
Internet Protocol 56 
Interoperability 82 
IP Routing 56 



Printed Documentation 

95 

J 

JPEG 65 

K 

Key expiration date 49 
Key Management 7, 49 
Key Ring Support 78 

L 

Language 25 
Language, Default 82 
Layout 3 
Lengthy installation 82 
Limit on Number of Topologies 30 
Linking 36 
Local Area Connection 56 
Localization settings 82 

M 

Manage Keys 7, 49 
Messages 20, 59 
Missing software 82 
MouseKey 82 
Mousewheel 23 
Multi-hop networking 82 
Multimedia clips 82 
Multiple Selections 23 

N 

Name 44 
Navigation 15 
NET 3.5 82 
Network 35, 42, 44, 45 
Network Connections 56 
Network security 82 
non-English Operating System 82 

O 

Open CPA 82 
Open Plan File 82 
Open View 30 
Other File Formats 81 

P 

Password 63 
Password recovery 49 

Plan Explorer 14 
Plan History 22 
Plan Information 16 
Plan validity 82 
Program Radio 21, 61 
Properties Window 16, 28, 47 
Property Editor 82 

Q 

Quick Start 2 

R 

Radio IP 56 
Read mission plan 82 
Recent Files 7 
Remove Station 48 
Reports 66 
Reset Tool 7 
Reset Window Layout 7 
Resize 23 
Restricted Key Operation 49 
RF-7800H-MP key rings 78 
Rotated image 82 

S 

Sample Plans 7, 29 
Save To JPEG 7 
Search 7 
Set Recovery Password 49 
Setting Default Station Properties 82 
Setting plan dates 82 
Station 36, 46 
Summary 2 
Supported Operating Systems 78 
Supported Products 7 
SW001 Firmware 82 
Switching topology views 82 

T 

Tabbed Views 3 
Tactical Chat IP export 7, 78 
TALON-based Products 82 
TCP/IP 56 
Third-party software 82 
Toolbox 11 
Tools Menu 7 
Tooltips 24 
Topology 30, 41 



 

96 

Troubleshoot compatibility issues 72 
Troubleshooting 82 

U 

Unrestricted Key Operation 49 
Using CPA without a mouse 82 
Using KGA-generated keys 49 
Using Sample Plans 29 

V 

Validation Summary 59 
View Menu 7 

View Plug-ins 7, 71 

W 

Welcome 1 
What's New 78 
Working with Keys 49 
Wrap text 82 

Z 

Zoom in/out 23 
Zoom to Fit 3 

 


	About This Help
	CPA Platform Help and Support
	Welcome
	Quick Start
	Help
	Interface Overview
	Window Layout and Options
	Window Layout
	Window Options
	Context Menus
	Toolbars
	Standard Toolbar
	Create Toolbar
	View Toolbar
	Tools Toolbar
	Actions Toolbar
	Favorites Toolbar
	Customizing Buttons
	Menus and Buttons
	File Menu
	View Menu
	Create Menu
	Actions Menu
	Tools Menu
	Window Menu
	Help Menu
	Toolbox
	How to Define Different Station Default Configurations
	How to Set Global Network Settings
	Plan Explorer
	Plan Navigator
	Properties
	Detail Dialogs (...)
	Expand All, Collapse All Buttons
	Add Properties as Favorites
	Search Properties
	Messages
	Programming Status
	Plan Notes
	Graphical Layout Tools
	Making Multiple Selections
	Tooltips
	Language Considerations

	Planning
	Planning Overview
	Installed Software Version Check
	Plan Information
	Using Sample Plans

	Constructing a Plan
	Working with Topologies
	Creating a Topology
	Using Connectivity View
	Using Open View
	Switching Topology Views
	Adding Networks
	Working with Items within Topology
	Property Pinning
	Adding Annotations
	Removing a Topology
	Working with Networks
	Creating Networks
	Wizard Network Creation
	Manual Network Creation
	Setting Network Properties
	Removing a Network
	Working with Stations
	Adding Stations
	Setting Station Properties
	Removing Stations
	Working with Keys
	Unrestricted Key Operation
	Parity
	Unrestricted Key Ring Generation
	Import Keys
	Restricted Key Operation
	Protected Keys
	SMT Keyloader

	Setting IP Addresses
	PC IP Addresses
	Radio IP Addresses

	Validating a Plan
	Programming Radios
	Support Tasks
	Configure Password
	Remove Password
	Export Plan Data
	Save to JPEG
	Create Reports
	Application Options
	View Plug-ins
	Configuration Extractor
	Create Map View
	Radio Monitoring


	Technical Support
	Support Overview
	What's New
	Supported Operating Systems
	Other OS Info

	Compatibility
	Import Keys
	Export Plan Data
	Other File Formats

	Troubleshooting
	Installation
	Configuration
	Operation
	Programming


	Glossary

	Index

